Volcanic ash emission

Ideas, problems or suggestions regarding the initialization of WRF Chemistry

Volcanic ash emission

Postby evanellope01 » Sun Jun 24, 2018 9:49 am

Good morning everybody,

I'm trying to understand how WRF-Chem works (I've worked with it for a few months), in particular I need to know how to insert in the model the emissions of a specific eruption (the 2010 Eyjafjoll volcano's eruption).

First, I modify the prep_chem_sources.inp file just defining the volcano of interest

use_volcanoes =1,
volcano_index =1449, !EYJAFJOLL

then I run the executable prep_chem_sources_RADM_WRF_FIM_.exe (that is in the same directory as the "inp" file and as the "Global emission dataset"). The program seems to finish successfully every time also, the output files don't seem to be empty. The problem comes out with the conversion: after modifying the namelist.input file in my wrf_run directory and linking all the intermediate format files I need to convert, I run convert_emiss.exe. The outputs are normally displayed but when I've try to open, for example, wrfchemv_d01 I get an error message similar to this one:

no displayable variables

I tried with different domains, but this didn't change anything. I fear that the problem is related to the options in the chemistry section of the namelist.input file.
I read the User's guide and also the Emission's Guide but I really don't find any help.

What I have to do, in general, is to insert in the model the emission of this particular eruption and then see how ash and dust are spread away from the volcano location.
I really appreciate any help or suggestion.

Posts: 1
Joined: Sun Jun 24, 2018 8:41 am

Re: Volcanic ash emission

Postby eiliscoleman » Mon Oct 22, 2018 5:41 am

Hi there,

Did you have any success? I am trying the same.

I run real.exe to generate wrfinput_d01
Then I create emissions using Prepchem 1.5
I use convert_emis.exe from WRF3.6 ( I recall that this program does not work for later versions of WRF).

However, there is some problem with defining the duration of eruption in either prepchem or convert_emis.exe, and hence when I use the create wrfchemv_d01 file in WRF3.9, the emissions are not integrated. Has anyone had similar issues? I'd be grateful of any advice.
Posts: 2
Joined: Wed Sep 19, 2018 6:05 am

Return to Initialization

Who is online

Users browsing this forum: No registered users and 1 guest