UPP Unipost failed running

Questions relating to the use of the WRF Post Processor V3

UPP Unipost failed running

Postby sabry81 » Fri Apr 27, 2012 11:45 am

Dear all,
I am using the UPPV1.1 to reformat the wrfout files produced by WRFARW to give them as input files to MET (Point-Stat) but I have a problem running "./run_unipost". The error message is:

+ 1> unipost_d01.001.out 2>& 1
+ mv WRFPRS001.tm00 WRFPRS_d01.001
mv: cannot stat `WRFPRS001.tm00': No such file or directory
+ ls -l WRFPRS_d01.001
ls: cannot access WRFPRS_d01.001: No such file or directory
+ err1=2
+ test 2 -ne 0
+ echo 'UNIPOST FAILED, EXITTING'
UNIPOST FAILED, EXITTING
+ exit

I compiled UPPV1.1 using the Settings for Linux x86_64, Intel compiler (serial)

Please, could you help me?
Thank you

Sabrina
sabry81
 
Posts: 1
Joined: Fri Apr 27, 2012 11:36 am

Re: UPP Unipost failed running

Postby rabon » Tue May 15, 2012 1:21 pm

Hi Sabrina,

have you found a solution to this issue? I keep stumbling over the same problem. I suspect that the error is with unipost not completing, but I have a hard time figuring out what the problem is.

Cheers,
Steffen

+ ln -sf griddef.out fort.110
+ mpirun -np 1 [PATH TO UPP]/UPPV1.1/bin/unipost.exe
+ < itag
+ > unipost_d03.000.out
+ 2>&1
+ mv WRFPRS000.tm00 WRFPRS_d03.000
mv: cannot stat `WRFPRS000.tm00': No such file or directory
+ ls -l WRFPRS_d03.000
ls: cannot access WRFPRS_d03.000: No such file or directory
+ err1=2
+ test 2 -ne 0
+ echo UNIPOST FAILED, EXITTING
UNIPOST FAILED, EXITTING
+ exit

rabon
 
Posts: 2
Joined: Tue May 15, 2012 1:18 pm

Re: UPP Unipost failed running

Postby rabon » Wed May 16, 2012 11:18 am

The issue is solved. For me, the problem was that my system doesn't accept the 'typeset -Z3' Option, which adds leading zeros to the $fhr variable. I wrote some lines adding the zeros to the filename in line 174 (or around there) to add the zero.

Code: Select all
if [[ ${fhr} -lt 100 ]]; then
mv WRFPRS0$fhr.${tmmark} WRFPRS_${domain}.${fhr}
else
mv WRFPRS$fhr.${tmmark} WRFPRS_${domain}.${fhr}
fi
rabon
 
Posts: 2
Joined: Tue May 15, 2012 1:18 pm

Re: UPP Unipost failed running

Postby lalitdagar » Mon Sep 17, 2012 10:38 pm

Hello,

I am also experiencing the same problem.

When I run UPP for the WRF output (installed at my local machine) it runs fine, however if i take output from my server and run UPP on my local machine then it gives the same problem. The log is as follow:

+ export TOP_DIR
+ WRF_DIR=/home/khub25/dagar/WRF/WRFV3
+ export WRF_DIR
+ DOMAINPATH=/home/khub25/dagar/WRF/UPPV1.1
+ export DOMAINPATH
+ WRFPATH=/home/khub25/dagar/WRF/WRFV3
+ export WRFPATH
+ UNI_POST_HOME=/home/khub25/dagar/WRF/UPPV1.1
+ export UNI_POST_HOME
+ POSTEXEC=/home/khub25/dagar/WRF/UPPV1.1/bin
+ export POSTEXEC
+ dyncore=ARW
+ [ ARW '=' NMM ]
+ [ ARW '=' ARW ]
+ tag=NCAR
+ export tag
+ startdate=2009011900
+ export startdate
+ fhr=00
+ export fhr
+ lastfhr=15
+ export lastfhr
+ incrementhr=1
+ export incrementhr
+ cd /home/khub25/dagar/WRF/UPPV1.1/postprd
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/postprd/ETAMPNEW_DATA eta_micro_lookup.dat
+ ln -fs ../parm/wrf_cntrl.parm wrf_cntrl.parm
+ CRTMDIR=/home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/EmisCoeff/Big_Endian/EmisCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/AerosolCoeff/Big_Endian/AerosolCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/CloudCoeff/Big_Endian/CloudCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/SpcCoeff/Big_Endian/imgr_g12.SpcCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/TauCoeff/Big_Endian/imgr_g12.TauCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/SpcCoeff/Big_Endian/imgr_g11.SpcCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/TauCoeff/Big_Endian/imgr_g11.TauCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/SpcCoeff/Big_Endian/amsre_aqua.SpcCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/TauCoeff/Big_Endian/amsre_aqua.TauCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/SpcCoeff/Big_Endian/tmi_trmm.SpcCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/TauCoeff/Big_Endian/tmi_trmm.TauCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/SpcCoeff/Big_Endian/ssmi_f15.SpcCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/TauCoeff/Big_Endian/ssmi_f15.TauCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/SpcCoeff/Big_Endian/ssmis_f20.SpcCoeff.bin ./
+ ln -fs /home/khub25/dagar/WRF/UPPV1.1/src/lib/crtm2/coefficients/TauCoeff/Big_Endian/ssmis_f20.TauCoeff.bin ./
+ tmmark=tm00
+ export tmmark
+ MP_SHARED_MEMORY=yes
+ export MP_SHARED_MEMORY
+ MP_LABELIO=yes
+ export MP_LABELIO
+ NEWDATE=2009011900
+ export NEWDATE
+ [ 00 -le 15 ]
+ typeset -Z3 fhr
+ /home/khub25/dagar/WRF/UPPV1.1/bin/ndate.exe +000 2009011900
+ NEWDATE=2009011900
+ cut -c1-4
+ echo 2009011900
+ YY=2009
+ cut -c5-6
+ echo 2009011900
+ MM=01
+ cut -c7-8
+ echo 2009011900
+ DD=19
+ cut -c9-10
+ echo 2009011900
+ HH=00
+ echo NEWDATE 2009011900
+ echo YY 2009
+ cat
+ 1> itag 0<< \EOF
/home/khub25/dagar/WRF/UPPV1.1/wrfprd/wrfout_d03_2009-01-19_00_00_00
netcdf
2009-01-19_00_00_00
NCAR
EOF
+ rm fort.110 fort.14
+ ln -sf wrf_cntrl.parm fort.14
+ ln -sf griddef.out fort.110
+ /home/khub25/dagar/WRF/UPPV1.1/bin/unipost.exe
+ 1> hindcast_d03.000.out 2>& 1
+ mv WRFPRS000.tm00 WRFPRS_d03.000
mv: cannot stat `WRFPRS000.tm00': No such file or directory
+ ls -l WRFPRS_d03.000
ls: cannot access WRFPRS_d03.000: No such file or directory
+ err1=2
+ test 2 -ne 0
+ echo 'UNIPOST FAILED, EXITTING'
+ exit


Any help will be greatly appreaciated.

Thanks
lalitdagar
 
Posts: 2
Joined: Mon Sep 17, 2012 10:33 pm

Re: UPP Unipost failed running

Postby centurion555 » Wed Oct 21, 2020 8:06 am

Any update ?
In my case it processes the first time-step but crashes on second time-step. Running "run_unipost_frames" with these parameters
export fhr=00
export lastfhr=47
export incrementhr=01

I get this output the following otuput. The logfile unipost_d01.00.out has no error but unipost_d01.01.out is empty.

NEWDATE 2006060100
YY 2006
+ HH=00
+ echo NEWDATE 2006060100
+ echo YY 2006
+ echo d01
+ cut -d d -f 2
+ dom_id=01
+ [[ ARW == ARW ]]
+ inFileName=/metstor_nfs/home/myuser/Softwares/WRF/200606/wrfprd/wrfout_d01_2006-06-01_00:00:00
+ [[ ! -e /metstor_nfs/home/myuser/Softwares/WRF/200606/wrfprd/wrfout_d01_2006-06-01_00:00:00 ]]
+ [[ grib == grib ]]
+ cat
+ 1> itag 0<< \EOF
/metstor_nfs/home/myuser/Softwares/WRF/200606/wrfprd/wrfout_d01_2006-06-01_00:00:00
netcdf
2006-06-01_00:00:00
NCAR
EOF
+ rm fort.14
+ ln -sf /metstor_nfs/home/myuser/Softwares/WRF/200606/parm/wrf_cntrl.parm fort.14
+ /metstor_nfs/home/myuser/Softwares/WRF/UPPV4.1/exec/unipost.exe
+ 1> unipost_d01.00.out 2>& 1
+ [[ ARW == ARW ]]
+ mv WRFPRS00.tm00 WRFPRS_d01.00
+ [[ ARW == ARW ]]
+ ls -l WRFPRS_d01.00
-rw-rw-r--. 1 myuser myuser 72238164 Oct 21 12:13 WRFPRS_d01.00
+ err1=0
+ test 0 -ne 0
+ fhr=1
+ date +%Y%m%d%H '--date=20060601 00 1 hour'
+ NEWDATE=2006060101
+ [ 1 -le 47 ]
+ printf %02i 1
+ fhr=01
+ date +%Y%m%d%H '--date=20060601 00 1 hour'
+ NEWDATE=2006060101
+ echo 2006060101
+ cut -c1-4
+ YY=2006
+ echo 2006060101
+ cut -c5-6
+ MM=06
+ echo 2006060101
+ cut -c7-8
+ DD=01
+ echo 2006060101
+ cut -c9-10
NEWDATE 2006060101
+ HH=01
+ echo NEWDATE 2006060101
+ echo YY 2006
YY 2006
+ echo d01
+ cut -d d -f 2
+ dom_id=01
+ [[ ARW == ARW ]]
+ inFileName=/metstor_nfs/home/myuser/Softwares/WRF/200606/wrfprd/wrfout_d01_2006-06-01_00:00:00
+ [[ ! -e /metstor_nfs/home/myuser/WRF/200606/wrfprd/wrfout_d01_2006-06-01_00:00:00 ]]
+ [[ grib == grib ]]
+ cat
+ 1> itag 0<< \EOF
/metstor_nfs/home/myuser/Softwares/WRF/200606/wrfprd/wrfout_d01_2006-06-01_00:00:00
netcdf
2006-06-01_01:00:00
NCAR
EOF
+ rm fort.110 fort.14
+ ln -sf /metstor_nfs/home/myuser/Softwares/WRF/200606/parm/wrf_cntrl.parm fort.14
+ /metstor_nfs/home/myuser/Softwares/WRF/UPPV4.1/exec/unipost.exe
+ 1> unipost_d01.01.out 2>& 1
+ [[ ARW == ARW ]]
+ mv WRFPRS01.tm00 WRFPRS_d01.01
mv: cannot stat ‘WRFPRS01.tm00’: No such file or directory
+ [[ ARW == ARW ]]
+ ls -l WRFPRS_d01.01
ls: cannot access WRFPRS_d01.01: No such file or directory
UNIPOST FAILED, EXITTING
+ err1=2
+ test 2 -ne 0
+ echo 'UNIPOST FAILED, EXITTING'
+ exit
centurion555
 
Posts: 3
Joined: Fri May 26, 2017 9:46 am


Return to WRF Post Processor V3

Who is online

Users browsing this forum: No registered users and 5 guests