WRF-Mars Compile Error

All things involving the setup (compiling, NetCDF, etc.) of the WRF Model itself.

WRF-Mars Compile Error

Postby bakamotokatas » Fri Nov 15, 2019 1:59 pm

Hello everyone, when I trying to compile WRF-Mars, I get error as the following which is intentionally putted for broke the compile that can be seen in https://github.com/wrf-model/WRF/blob/master/dyn_em/module_first_rk_step_part2.F between line 761 and 767.

Code: Select all
rm -f module_first_rk_step_part2.G module_first_rk_step_part2.bb
time mpif90  -o module_first_rk_step_part2.o -c -O2 -ftree-vectorize -funroll-loops -w -ffree-form -ffree-line-length-none -fconvert=big-endian -frecord-marker=4   -I../dyn_em -I../dyn_nmm  -I/home/bakamotokatas/Build_WRF/WRF-4.1.2/external/esmf_time_f90  -I/home/bakamotokatas/Build_WRF/WRF-4.1.2/main -I/home/bakamotokatas/Build_WRF/WRF-4.1.2/external/io_netcdf -I/home/bakamotokatas/Build_WRF/WRF-4.1.2/external/io_int -I/home/bakamotokatas/Build_WRF/WRF-4.1.2/frame -I/home/bakamotokatas/Build_WRF/WRF-4.1.2/share -I/home/bakamotokatas/Build_WRF/WRF-4.1.2/phys -I/home/bakamotokatas/Build_WRF/WRF-4.1.2/wrftladj -I/home/bakamotokatas/Build_WRF/WRF-4.1.2/chem -I/home/bakamotokatas/Build_WRF/WRF-4.1.2/inc -I/usr/include    module_first_rk_step_part2.f90
module_first_rk_step_part2.f90:908:1:

  908 | =============================================================
      | 1
Error: Invalid character in name at (1)
module_first_rk_step_part2.f90:909:6:

  909 | INTENTIONALLY PLACED HERE TO BREAK COMPILE
      |      1
Error: Bad INTENT specification at (1)
module_first_rk_step_part2.f90:910:2:

  910 | 1. The DAMPTOP routine needs to have 1d column arrays c1 and c2
      |  1
Error: Non-numeric character in statement label at (1)
module_first_rk_step_part2.f90:912:2:

  912 | 2. The DAMPTOP routine needs to have the grid%t_2 evaluated
      |  1
Error: Non-numeric character in statement label at (1)
module_first_rk_step_part2.f90:914:1:

  914 | =============================================================
      | 1
Error: Invalid character in name at (1)
Command exited with non-zero status 1




I tried the remove lines that broke the compile, but i get other errors. What can i do to fix it?

Thanks for answers..
bakamotokatas
 
Posts: 3
Joined: Thu Jul 13, 2017 5:18 pm

Return to Installation

Who is online

Users browsing this forum: No registered users and 7 guests