Page 2 of 2

Re: sst update with WRF NMM

PostPosted: Sat Apr 04, 2015 9:50 am
by joe wen
Dear sir or Madam´╝î
I need your help please.
###################
./ungrib.exe
*** Starting program ungrib.exe ***
Start_date = 2014-07-18_00:00:00 , End_date = 2014-07-19_00:00:00
output format is WPS
Path to intermediate files is ./
ERROR: Grib2 file or date problem, stopping in edition_num.
Warning: ieee_inexact is signaling
FORTRAN STOP
######################
namelist.wps
&share
wrf_core = 'ARW',
max_dom = 2,
start_date = '2014-07-18_00:00:00','2014-07-18_00:00:00'
end_date = '2014-07-19_00:00:00','2014-07-19_00:00:00'
interval_seconds = 21600
io_form_geogrid = 2,
/

&geogrid
parent_id = 1, 1,
parent_grid_ratio = 1, 3,
i_parent_start = 1, 31,
j_parent_start = 1, 17,
e_we = 74, 112,
e_sn = 61, 97,
geog_data_res = '10m','2m',
dx = 30000,
dy = 30000,
map_proj = 'mercator',
ref_lat = 18.59,
ref_lon = -19.50,
truelat1 = 30.0,
truelat2 = 60.0,
stand_lon = -98.0,
geog_data_path = '/../wrf/geog'
/

&ungrib
out_format = 'WPS',
prefix = 'FILE',
/

&metgrid
fg_name = 'FILE'
io_form_metgrid = 2,
/
#######################

GRIBFILE.AAA -> /.../test/fnl_20140718_00_00.grib2.nc
GRIBFILE.AAB -> /.../test/fnl_20140718_06_00.grib2.nc
GRIBFILE.AAC -> /.../test/fnl_20140718_12_00.grib2.nc
GRIBFILE.AAD -> /.../test/fnl_20140718_18_00.grib2.nc

Re: sst update with WRF NMM

PostPosted: Fri Dec 04, 2015 2:18 pm
by alainaketh
Hi all,

In my case, I wasn't linking properly my files. I had my atmospheric data downloaded from http://rda.ucar.edu/datasets/ds083.2/ in a directory named ~/build_WRF/DATA. In said directory I had lots of fnl_20090804_blabla files, so the problem was solved by typing (first of course be sure you're in the WPS directory):

Code: Select all
./link_grib.csh ~/build_WRF/DATA/fnl*


And that was it.

Re: sst update with WRF NMM

PostPosted: Fri Nov 02, 2018 4:12 am
by mml373
richard_n413 wrote:This thread is now probably off the topic of the previous post, but I shall contribute further to this :)

I encountered the problem "Error: grib2 file or date problem, stopping in edition_num" when using ./ungrib. My problem was that I was linking to a directory, rather than a file using ./link_grib.csh.

For example, my data is stored in "/home/user/Documents/Build_WRF/DATA", and I was using the command
Code: Select all
./link_grib.csh /home/user/Documents/Build_WRF/DATA

while the correct command should have been
Code: Select all
./link_grib.csh /home/user/Documents/Build_WRF/DATA/*

to get the files rather than the directory. Presumably the ungrib.exe was trying to ungrib the folder, and not the stuff in the folder.

Hope this helps.


Indeed...this was the fix for me! Simple... Thank you!