Problems running lake scheme in WRF

Topics related to current and future physics in the WRF as well as any problems you may have.

Problems running lake scheme in WRF

Postby bronbron85 » Wed Oct 25, 2017 11:14 pm

I would like to run the lake scheme in WRF. I added the following line to my namelist.input file under the physics options:

sf_lake_physics = 1, 1, 1,

However the SST over my lake is the same as before I added this line to switch the lake model on, indicating the lake model did not correctly.

Here is a full copy of my namelist file. Please let me know if you can help. Thanks :)

&time_control
run_days = 26
run_hours = 0
run_minutes = 0
run_seconds = 0
start_year = 2012, 2012, 2012,
start_month = 05, 05, 05,
start_day = 07, 07, 07,
start_hour = 00, 00, 00,
start_minute = 00, 00, 00,
start_second = 00, 00, 00,
end_year = 2012, 2012, 2012,
end_month = 06, 06, 06,
end_day = 02, 02, 02,
end_hour = 00, 00, 00,
end_minute = 00, 00, 00,
end_second = 00, 00, 00,
interval_seconds = 21600
input_from_file = .true.,.true.,.true.,
history_interval = 180, 60, 30,
frames_per_outfile = 8, 24, 48,
restart = .false.,
restart_interval = 1440,
override_restart_timers = .true.,
write_hist_at_0h_rst = .true.
io_form_history = 2
io_form_restart = 2
io_form_input = 2
io_form_boundary = 2
debug_level = 999
io_form_auxinput4 = 2 ! this is to use sst data
auxinput4_inname = "wrflowinp_d<domain>",
auxinput4_interval = 360, 360, 360,
/

&domains
time_step = 60,
time_step_fract_num = 0,
time_step_fract_den = 1,
max_dom = 3,
e_we = 340,328,526,
e_sn = 245,235,371,
e_vert = 30,30,30,
eta_levels = 1.00,0.995,0.99,0.98,0.97,0.96,0.94,0.92,0.89,0.86,0.83,0.80,0.77,0.72,0.67,0.62,0.57,0.52,0.47,0.42,0.37,0.32,0.27,0.22,0.17,0.12,0.07,0.04,0.02,0.00
p_top_requested = 5000,
num_metgrid_levels = 38,
num_metgrid_soil_levels = 4,
sfcp_to_sfcp = .true.,
use_surface = .false.,
dx = 15000,5000,1000,
dy = 15000,5000,1000,
grid_id = 1, 2, 3,
parent_id = 0, 1, 2,
i_parent_start = 1,116,112,
parent_grid_ratio = 1,3,5
parent_time_step_ratio = 1,3,5
feedback = 0,
smooth_option = 0
/

&physics
mp_physics = 3, 3, 3,
ra_lw_physics = 4, 4, 4,
ra_sw_physics = 1, 1, 1,
radt = 30, 30, 30,
sf_sfclay_physics = 1, 1, 1,
sf_surface_physics = 2, 2, 2,
sf_urban_physics = 1, 1, 1,
bl_pbl_physics = 1, 1, 1,
bldt = 0, 0, 0,
cu_physics = 2, 2, 0,
cudt = 5, 5, 0,
isfflx = 1,
ifsnow = 0,
icloud = 1,
surface_input_source = 1,
num_soil_layers = 4,
maxiens = 1,
maxens = 3,
maxens2 = 3,
maxens3 = 16,
ensdim = 144,
num_land_cat = 21,
sst_update = 1, ! from J.Evans script to use sst data
sf_lake_physics = 1, 1, 1,
/


&dynamics
w_damping = 0,
diff_opt = 1,
km_opt = 4,
diff_6th_opt = 0, 0, 0,
diff_6th_factor = 0.12, 0.12, 0.12,
base_temp = 290.
damp_opt = 0,
zdamp = 5000., 5000., 5000.,
dampcoef = 0.2, 0.2, 0.2 ,
khdif = 0, 0, 0,
kvdif = 0, 0, 0,
non_hydrostatic = .true., .true., .true.,
moist_adv_opt = 1, 1, 1,
scalar_adv_opt = 1, 1, 1,
/

&bdy_control
spec_bdy_width = 5,
spec_zone = 1,
relax_zone = 4,
specified = .true., .false.,.false.,
nested = .false., .true., .true.,
/

&grib2
/

&namelist_quilt
nio_tasks_per_group = 0,
nio_groups = 1,
/
bronbron85
 
Posts: 2
Joined: Sat Sep 23, 2017 3:11 am

Return to Physics

Who is online

Users browsing this forum: No registered users and 2 guests