GEOGRID.EXE can´t create geo_em.d01.nc file for Antartica

Any issues with the actual running of the WRF.

GEOGRID.EXE can´t create geo_em.d01.nc file for Antartica

Postby gadelha » Tue Aug 15, 2017 8:17 am

Hy guys!

I used to run WRF to Antarctic area with the bellow namelist.wps file without problems, but after GFS changes it no longer runs!

I need to highlight that I´ve made the changes sugested at http://www2.mmm.ucar.edu/wrf/users/wpsv ... b-3.9.html and I use the same binary to run WPS to Brazil, without problems. The issue only happens when I try to run it to antarctic. The geogrid.exe stucks at greenfrac step!

Can anybody use the namelist.wps file bellow to try to create the geo_em.d01.nc file, please?

Thank´s for your help!


&share
wrf_core = 'ARW',
max_dom = 1,
start_date = '2017-08-15_00:00:00','2017-08-15_00:00:00',
end_date = '2017-08-15_00:00:00','2017-08-15_00:00:00',
interval_seconds = 10800
io_form_geogrid = 2,
debug_level = 0
/

&geogrid
parent_id = 1, 1,
parent_grid_ratio = 1, 5,
i_parent_start = 1, 225,
j_parent_start = 1, 180,
e_we = 400, 9999,
e_sn = 330, 9999,
geog_data_res = '2m','2m',
dx = 15000,
dy = 15000,
map_proj = 'polar',
ref_lat = -62.163,
ref_lon = -69.789,
truelat1 = -62.163,
truelat2 = -90,
stand_lon = -69.789,
geog_data_path = '/home/wrfoperador/wrf/geog'
opt_geogrid_tbl_path = './'
/

&ungrib
out_format = 'WPS',
prefix = 'FILE',
/

&metgrid
fg_name = 'FILE'
io_form_metgrid = 2,
opt_output_from_metgrid_path = './',
opt_metgrid_tbl_path = './',
/

&mod_levs
press_pa = 201300 , 200100 , 100000 ,
95000 , 90000 ,
85000 , 80000 ,
75000 , 70000 ,
65000 , 60000 ,
55000 , 50000 ,
45000 , 40000 ,
35000 , 30000 ,
25000 , 20000 ,
15000 , 10000 ,
5000 , 1000
/
gadelha
 
Posts: 23
Joined: Wed Aug 12, 2009 10:11 am

Re: GEOGRID.EXE can´t create geo_em.d01.nc file for Antartic

Postby dcvz » Fri Aug 18, 2017 3:20 am

You are correct, this doesn't work. It looks like it was broken since 2014.

I was able to get it to work by modifying the GEOGRID.TBL.
In the GREENFRAC entry change

rel_path=default:greenfrac_fpar_modis/
to
rel_path=default:greenfrac/

Delete the entries for LAI2M and URB_PARAM entirely.

The problem has something to do with modis_fpar data over Antarctica. It's possible that given enough computer time (who knows how long - 2 weeks?) geogrid.exe would have completed.

I would also suggest removing &mod_levs section from your namelist since almost no one uses it. Also, whenever you have trouble with WPS set debug_level = 1000. It wouldn't have helped with this problem, but it's good practice.
dcvz
 
Posts: 175
Joined: Tue Apr 15, 2008 12:02 am

Re: GEOGRID.EXE can´t create geo_em.d01.nc file for Antartic

Postby gadelha » Sat Apr 21, 2018 9:36 am

Thanks dcvz for reply! It works. However, I would like to understand the impact of that change. What´s the meaning of LAI2M "leaf area index"?

Where to find how manipulate this table?

Thanks again!
gadelha
 
Posts: 23
Joined: Wed Aug 12, 2009 10:11 am


Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 8 guests