problem ./run_wrfpost

Questions relating to the use of the WRF Post Processor V3

problem ./run_wrfpost

Postby apextreme » Mon Apr 26, 2010 4:58 pm

I have problem.
When run WRF POST PROCESOR give me one error:

wrf@stratus:~/wrf3.2/nam/WPPV3/scripts$ ./run_wrfpost
+ TOP_DIR=/home/wrf/wrf3.2/nam
+ export TOP_DIR
+ DOMAINPATH=/home/wrf/wrf3.2/nam/DOMAINS/fir1
+ export DOMAINPATH
+ dyncore=NMM
+ [ NMM = NMM ]
+ tag=NMM
+ export tag
+ startdate=2010042612
+ export startdate
+ fhr=00
+ export fhr
+ lastfhr=72
+ export lastfhr
+ incrementhr=01
+ export incrementhr
+ WRF_POSTPROC_HOME=/home/wrf/wrf3.2/nam/WPPV3
+ export WRF_POSTPROC_HOME
+ POSTEXEC=/home/wrf/wrf3.2/nam/WPPV3/exec
+ export POSTEXEC
+ SCRIPTS=/home/wrf/wrf3.2/nam/WPPV3/scripts
+ export SCRIPTS
+ WRFPATH=/home/wrf/wrf3.2/nam/WRFV3
+ export WRFPATH
+ cd /home/wrf/wrf3.2/nam/DOMAINS/fir1/postprd
+ ln -fs /home/wrf/wrf3.2/nam/WRFV3/run/ETAMPNEW_DATA eta_micro_lookup.dat
+ ln -fs /home/wrf/wrf3.2/nam/DOMAINS/fir1/parm/wrf_cntrl.parm .
/home/wrf/wrf3.2/nam/DOMAINS/fir1/postprd
+ tmmark=tm00
+ export tmmark
+ MP_SHARED_MEMORY=yes
+ export MP_SHARED_MEMORY
+ MP_LABELIO=yes
+ export MP_LABELIO
+ pwd
+ ls -x
eta_micro_lookup.dat wrf_cntrl.parm
+ NEWDATE=2010042612
+ export NEWDATE
+ [ 00 -le 72 ]
+ typeset -Z3 fhr
+ /home/wrf/wrf3.2/nam/WPPV3/exec/ndate.exe +000 2010042612
+ NEWDATE=2010042612
+ cut -c1-4
+ echo 2010042612
+ YY=2010
+ echo 2010042612
+ cut -c5-6
+ MM=04
+ cut -c7-8
+ echo 2010042612
+ DD=26
+ cut -c9-10
+ echo 2010042612
+ HH=12
+ echo NEWDATE 2010042612
NEWDATE 2010042612
+ echo YY 2010
YY 2010
+ cat
+ 1> itag 0<< \EOF
../wrfprd/wrfout_d01_2010-04-26_12:00:00
netcdf
2010-04-26_12:00:00
NMM
EOF
+ rm 'fort.*'
rm: no se puede borrar «fort.*»: No existe el fichero ó directorio
+ ln -sf wrf_cntrl.parm fort.14
+ ln -sf griddef.out fort.110
+ /home/wrf/wrf3.2/nam/WPPV3/exec/wrfpost.exe
+ 0< itag 1> wrfpost_d01.000.out 2>& 1
+ mv WRFPRS000.tm00 WRFPRS_d01.000
+ ls -l WRFPRS_d01.000
-rwxrwxr-x 1 wrf wrf 532834 2010-04-26 17:07 WRFPRS_d01.000
+ err1=0
+ test 0 -ne 0
+ [ NMM = NMM ]
+ read nav
+ 0< copygb_gridnav.txt
+ export nav
+ /home/wrf/wrf3.2/nam/WPPV3/exec/copygb.exe '-xg255 3 45 57 -20577 -71010 8 -69655 6206 6380 128 64 -18967 -18967 -90000 0' WRFPRS_d01.000 wrfprs_d01.000
+ ls -l wrfprs_d01.000
-rwxrwxr-x 1 wrf wrf 1084972 2010-04-26 17:07 wrfprs_d01.000
+ err1=0
+ test 0 -ne 0
+ let fhr=fhr+1
+ /home/wrf/wrf3.2/nam/WPPV3/exec/ndate.exe +001 2010042612
+ NEWDATE=2010042613
+ [ 001 -le 72 ]
+ typeset -Z3 fhr
+ /home/wrf/wrf3.2/nam/WPPV3/exec/ndate.exe +001 2010042612
+ NEWDATE=2010042613
+ echo 2010042613
+ cut -c1-4
+ YY=2010
+ echo 2010042613
+ cut -c5-6
+ MM=04
+ cut -c7-8
+ echo 2010042613
+ DD=26
+ echo 2010042613
+ cut -c9-10
+ HH=13
+ echo NEWDATE 2010042613
NEWDATE 2010042613
+ echo YY 2010
YY 2010
+ cat
+ 1> itag 0<< \EOF
../wrfprd/wrfout_d01_2010-04-26_13:00:00
netcdf
2010-04-26_13:00:00
NMM
EOF
+ rm fort.110 fort.14
+ ln -sf wrf_cntrl.parm fort.14
+ ln -sf griddef.out fort.110
+ /home/wrf/wrf3.2/nam/WPPV3/exec/wrfpost.exe
+ 0< itag 1> wrfpost_d01.001.out 2>& 1
+ mv WRFPRS001.tm00 WRFPRS_d01.001
mv: no se puede efectuar `stat' sobre «WRFPRS001.tm00»: No existe el fichero ó directorio
+ ls -l WRFPRS_d01.001
ls: no se puede acceder a WRFPRS_d01.001: No existe el fichero ó directorio
+ err1=2
+ test 2 -ne 0
+ echo 'WRF POST FAILED, EXITTING'
WRF POST FAILED, EXITTING
+ exit


What's the problem?
Help Please!!!
Thank's
apextreme
 
Posts: 47
Joined: Thu Nov 05, 2009 9:58 am

Re: problem ./run_wrfpost

Postby pmoreira » Tue Jun 01, 2010 4:22 pm

Easier to evaluate if you provide your run_wrfpost file! :)
pmoreira
 
Posts: 18
Joined: Wed Mar 03, 2010 7:13 pm


Return to WRF Post Processor V3

Who is online

Users browsing this forum: No registered users and 1 guest