Memory fault

Questions relating to the use of the WRF Post Processor V3

Re: Memory fault

Postby lfragkou » Thu Jul 29, 2010 10:23 am

Hello all,

I am a new WRF user and I am encountering exactly the same problem with the "memory fault" error message when trying to run the WRFPP, compiled using the pgi compiler.

I would be really grateful to you if you could sent some hints on how to solve this.

Thank you!
lfragkou
 
Posts: 2
Joined: Thu Jul 29, 2010 9:50 am

Re: Memory fault

Postby hejianjun » Mon Oct 18, 2010 10:28 pm

before run wrfpost.exe,
ulimit -s unlimited
it's ok.
hejianjun
 
Posts: 5
Joined: Mon Oct 18, 2010 12:18 pm

Re: Memory fault

Postby Arni » Mon Jun 20, 2011 5:02 am

I did change my TOPDIR path in the run_wrfpost-file from

/home2/Etcetera...

to

home2/Etcetera

and the error disappeared
Arni
 
Posts: 1
Joined: Fri Mar 18, 2011 4:13 pm

Re: Memory fault

Postby weatherwatcher » Thu Feb 28, 2013 7:17 am

I had the same problem. Just changed dyncore option at line 39 in run_unipost and it's ok now (ARW instead of NMM) !
weatherwatcher
 
Posts: 9
Joined: Wed Oct 19, 2011 3:19 am

Re: Memory fault

Postby giovi » Wed Mar 27, 2013 1:47 pm

Hi,

I am trying to run WPP, and I have the exact same error, about the segmentation fault. Did anyone figure this one out?

kind regards

Giovanna
giovi
 
Posts: 3
Joined: Wed Mar 27, 2013 1:00 pm

Re: Memory fault

Postby REKHA BHARALI GOGOI » Wed May 08, 2013 5:29 am

Although its a very old post but still it may help someone.
Before running the run_wrfpost script just give the following command:
ulimit -s unlimited

It solved the memory problem in my case.
REKHA BHARALI GOGOI
 
Posts: 34
Joined: Fri Oct 22, 2010 5:45 am

Re: Memory fault

Postby amiraebrahim93 » Thu Aug 27, 2015 5:36 am

Hi
could you help me to solve my problem
when i make run for the unipost of wrf i find this problem
mv WRFPRS00.tm00 WRFPRS_d01.00
mv: cannot stat ‘WRFPRS00.tm00’: No such file or directory
+ ls -l WRFPRS_d01.00
ls: cannot access WRFPRS_d01.00: No such file or directory
+ err1=2
+ test 2 -ne 0
+ echo 'UNIPOST FAILED, EXITTING'
UNIPOST FAILED, EXITTING
regards
amiraebrahim93
 
Posts: 2
Joined: Thu Aug 27, 2015 5:28 am

Previous

Return to WRF Post Processor V3

Who is online

Users browsing this forum: No registered users and 3 guests