Memory fault

Questions relating to the use of the WRF Post Processor V3

Memory fault

Postby kryzam » Tue Sep 01, 2009 6:33 am

Hello,
I get "Memory fault" message when trying to run wrfpost.exe on Linux Fedora 11. WRFPP was compiled with no error messages.
Please can someone give me any hints how to solve this problem?
Best regards,
kryzam
 
Posts: 6
Joined: Tue Sep 01, 2009 6:25 am

Re: Memory fault

Postby jaareval » Tue Sep 01, 2009 3:14 pm

I'm having the same problem. I compiled WPPV3 with gfortran. The wrfpost output file only says "Segmentation fault". I tried add ulimit -s unlimited, but i got the same error message.

Thanks
Jorge Arevalo B.
Ceaza - Universidad de La Serena
jaareval
 
Posts: 5
Joined: Mon Jun 30, 2008 2:05 pm
Location: Valparaiso

Re: Memory fault

Postby wrfu » Tue Sep 01, 2009 10:33 pm

I am having the same problem when I run the script in WPPV3 with WRF-ARW output on my computer system. Here are errors on the screen.

0< itag 1> wrfpost_d01.24.out 2>& 1
./run_wrfpost: line 118: 20194: Memory fault
+ mv WRFPRS24.tm00 WRFPRS_d01.24
mv: cannot stat `WRFPRS24.tm00': No such file or directory
+ ls -l WRFPRS_d01.24
ls: WRFPRS_d01.24: No such file or directory
+ err1=2
+ test 2 -ne 0
+ echo 'WRF POST FAILED, EXITTING'
WRF POST FAILED, EXITTING
+ exit

Any suggestions would be appriciate
wrfu
 

Re: Memory fault

Postby Patrik Norman » Thu Sep 17, 2009 4:00 am

I think that I have the same problem:
+ /home/wrfuser1/WRF/WPPV3/exec/wrfpost.exe
+ 0< itag 1> wrfpost_d01.012.out 2>& 1
./run_wrfpost: line 117: 25191: Memory fault
+ mv WRFPRS012.tm00 WRFPRS_d01.012

line 117:
${POSTEXEC}/wrfpost.exe < itag > wrfpost_${domain}.$fhr.out 2>&1

I'm running Ubuntu 9.04 in 64 bit and use the gfortran 4.3.3 compiler. My hardware is a Dell Precision T7500 with 8 cores and 8 GB of RAM (but I still run just in serial mode until I have tried it out).

I have written to wrf-help about this and hopefully they can help me to solve it. If so I will post the solution here.
Patrik Norman
 
Posts: 2
Joined: Fri Jun 12, 2009 6:02 am

Re: Memory fault

Postby total » Wed Sep 30, 2009 6:04 am

Hi,

I have the same problem.
Any suggestions?? :roll:

Thanks
total
 
Posts: 10
Joined: Wed Sep 30, 2009 5:57 am

Re: Memory fault

Postby infagon » Mon Oct 19, 2009 6:18 am

hello,
i also have a this problem when tryinf to execute wrfpost.exe.
+ 1> itag ../wrfprd/wrfout_d01_2005-01-23_00:00:00
netcdf
2005-01-23_00:00:00
NMM
0<<
+ rm fort.110 fort.14
+ ln -sf wrf_cntrl.parm fort.14
+ ln -sf griddef.out fort.110
+ /home/bcodina/wrf/WPPV3/exec/wrfpost.exe
+ 0< itag 1> wrfpost_d01.000.out 2>& 1
+ mv WRFPRS000.tm00 WRFPRS_d01.000
mv: cannot stat `WRFPRS000.tm00': No such file or directory
+ ls -l WRFPRS_d01.000
ls: WRFPRS_d01.000: No such file or directory
+ err1=2
+ test 2 -ne 0
+ echo 'WRF POST FAILED, EXITTING'
WRF POST FAILED, EXITTING
+ exit
I am also trying to figure out what the itag command is doing...
Has anyone any idea on how to solve this
Regards
Gonzalo Infante
infagon
 
Posts: 9
Joined: Mon Oct 05, 2009 3:57 pm

Re: Memory fault

Postby infagon » Mon Oct 19, 2009 7:07 am

The error is related with the execution of wrfpost.exe.
Here i put some lines of this file:

status for getting TSTART= -1021
TSTART= 1.3085006E+22
status for getting RESTARTBIN= -1021
Is this a restrt run? T
forrtl: error (65): floating invalid
Image PC Routine Line Source
wrfpost.exe 00000000004DF242 initpost_nmm_ 246 INITPOST_NMM.f
wrfpost.exe 000000000052099A MAIN__ 378 WRFPOST.f
wrfpost.exe 00000000004043C2 Unknown Unknown Unknown
libc.so.6 00000030E341D8B4 Unknown Unknown Unknown
wrfpost.exe 00000000004042E9 Unknown Unknown Unknown
45,1 Bot
for me it looks like there s a compilation error.
Has anyone any idea????
Thanks
infagon
 
Posts: 9
Joined: Mon Oct 05, 2009 3:57 pm

Re: Memory fault

Postby cristian.recabarren » Thu Nov 05, 2009 6:47 pm

to solve this problem i've added those lines to run_wrfpost script:

fail=0
flag=1
a=`ls WRFPRS???.tm00 | cut -c7-9`

while [ $flag -eq 1 ]; do
if [ -e WRFPRS\*\*\*.tm00 ]; then
while [ -e WRFPRS\*\*\*.tm00 ]; do
rm WRFPRS\*\*\*.tm00
echo "Bad file was created running again"
let fail=$fail+1
ln -sf wrf_cntrl.parm fort.14
ln -sf griddef.out fort.11
${POSTEXEC}/wrfpost.exe < itag > wrfpost_${domain}.$fhr.out 2>&1
done
flag=0
if [ -e WRFPRS???.tm00 ]; then
flag=1
fi
else
while [ $a -ne $fhr ]; do
rm WRFPRS???.tm00
echo "Bad file was created, runing again"
let fail=$fail+1
ln -sf wrf_cntrl.parm fort.14
ln -sf griddef.out fort.11
${POSTEXEC}/wrfpost.exe < itag > wrfpost_${domain}.$fhr.out 2>&1
a=`ls WRFPRS???.tm00 | cut -c7-9`
done
flag=0
if [ -e WRFPRS\*\*\*.tm00 ]; then
flag=1
fi
fi
flag=0
done

echo "wrfpost.exe run bad $fail times"

between:
${POSTEXEC}/wrfpost.exe < itag > wrfpost_${domain}.$fhr.out 2>&1 ### line 121

and
mv WRFPRS$fhr.tm00 WRFPRS_${domain}.${fhr}
cristian.recabarren
 
Posts: 1
Joined: Thu Nov 05, 2009 6:38 pm

Re: Memory fault

Postby total » Fri Nov 06, 2009 10:41 am

Hi,

I modify my script run_wrfpost and I run the script ./run_wrfpost and I get this message :


+ NEWDATE=2005082800
+ export NEWDATE
+ [ 00 -le 18 ]
+ typeset -Z2 fhr
+ /bexelappl/WRF/WPPV3/exec/ndate.exe +00 2005082800
+ NEWDATE=2005082800
+ echo 2005082800
+ cut -c1-4
+ YY=2005
+ echo 2005082800
+ cut -c5-6
+ MM=08
+ echo 2005082800
+ cut -c7-8
+ DD=28
+ echo 2005082800
+ cut -c9-10
+ HH=00
+ echo NEWDATE 2005082800
NEWDATE 2005082800
+ echo YY 2005
YY 2005
+ cat
+ 1> itag ../wrfprd/wrfout_d01_2005-08-28_00:00:00
netcdf
2005-08-28_00:00:00
NCAR
0<<
+ rm fort.110 fort.14
+ ln -sf wrf_cntrl.parm fort.14
+ ln -sf griddef.out fort.110
+ /bexelappl/WRF/WPPV3/exec/wrfpost.exe
+ 0< itag 1> wrfpost_d01.00.out 2>& 1
./run_wrfpost: line 117: 23487: Memory fault
+ fail=0
+ flag=1
+ ls 'WRFPRS???.tm00'
ls: WRFPRS???.tm00: No such file or directory
+ cut -c7-9
+ a=''
+ [ 1 -eq 1 ]
+ [ -e 'WRFPRS***.tm00' ]
+ [ -ne 00 ]
./run_wrfpost[140]: [: argument expected
+ flag=0
+ [ -e 'WRFPRS***.tm00' ]
+ flag=0
+ [ 0 -eq 1 ]
+ echo 'wrfpost.exe run bad 0 times'
wrfpost.exe run bad 0 times
+ mv WRFPRS00.tm00 WRFPRS_d01.00
mv: cannot stat `WRFPRS00.tm00': No such file or directory
+ ls -l WRFPRS_d01.00
ls: WRFPRS_d01.00: No such file or directory
+ err1=2
+ test 2 -ne 0
+ echo 'WRF POST FAILED, EXITTING'
WRF POST FAILED, EXITTING
+ exit


any idea?
total
 
Posts: 10
Joined: Wed Sep 30, 2009 5:57 am

Re: Memory fault

Postby SeBi013 » Wed Feb 10, 2010 5:19 am

Hi,

nobody have an idea to solve this problem ? :?

Sebastien D.
SeBi013
 
Posts: 35
Joined: Sun Oct 25, 2009 4:55 pm
Location: Belgium

Next

Return to WRF Post Processor V3

Who is online

Users browsing this forum: No registered users and 2 guests

cron