WRF 3.5 but ungrib.exe problem

All things involving the setup (compiling, NetCDF, etc.) of the WRF Model itself.

WRF 3.5 but ungrib.exe problem

Postby shahadat » Mon Jun 03, 2013 6:27 am

I installed wrf3.5, all step are successfully installed. also geogrid.exe successfully completed. but when i run ungrib.exe and it make error. Error is:--
./ungrib.exe: error while loading shared libraries: libpng16.so.16: cannot open shared object file: No such file of directory.
please help anyone. What should i do?
shahadat
 
Posts: 9
Joined: Mon Feb 04, 2013 6:00 am

Re: WRF 3.5 but ungrib.exe problem

Postby shahadat » Tue Jun 04, 2013 5:57 am

Don't try it, i have solved it.
shahadat
 
Posts: 9
Joined: Mon Feb 04, 2013 6:00 am

Re: WRF 3.5 but ungrib.exe problem

Postby bossma » Sun Nov 13, 2016 1:13 pm

shahadat wrote:Don't try it, i have solved it.

could u please tell me how to solve it
i have the same problem
bossma
 
Posts: 1
Joined: Sun Nov 13, 2016 1:10 pm

Re: WRF 3.5 but ungrib.exe problem

Postby kwthomas » Mon Nov 14, 2016 5:40 pm

Your executable didn't get built correctly, so the location of "libpng16.so.16" didn't get coded into it. You'll have to find where it is built on your system. You'll have to create/alter the
LD_LIBRARY_PATH environmental variable.

For example, if it is in /usr/libpng

If not set:
set LD_LIBRARY_PATH=/usr/libpng

If set:
set LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/usr/libpng

This is csh/tcsh syntax. Bash and other shells likely use a different syntax. Check your login
shell man page. Your System Admin may be able to help too.

You might also try a later version of WRF. More recent versions may not have been fixed.
Kevin W. Thomas
Center for Analysis and Prediction of Storms
University of Oklahoma
kwthomas
 
Posts: 168
Joined: Thu Aug 07, 2008 6:53 pm


Return to Installation

Who is online

Users browsing this forum: Baidu [Spider] and 4 guests