Error!!! Geogrid.exe & Metgrid in WRF3.7.1

Introduction to the forum

Error!!! Geogrid.exe & Metgrid in WRF3.7.1

Postby shahadat » Wed Jan 13, 2016 10:58 pm

Hello,

I am having trouble getting all of the executables needed to run WPS, when i compile, its create only ungrib.exe but can't create geogrid.exe & metgrid.exe......
Error is given below... when i comple WPS....


Code: Select all
/usr/lib64/mpich/lib: file not recognized: Is a directory
collect2: error: ld returned 1 exit status
make[1]: [geogrid.exe] Error 1 (ignored)
make[1]: Leaving directory `/home/WRF/WPS/geogrid/src'


also error image is ... http://postimg.org/image/472c1cxj1/full/

Also same type of error is given for metgrid.exe. i am using Centos 7 (core).....

I am not sure what to do, any help would be greatly appreciated.

Shahadat, Bangladesh
shahadat
 
Posts: 9
Joined: Mon Feb 04, 2013 6:00 am

Re: Error!!! Geogrid.exe & Metgrid in WRF3.7.1

Postby kwthomas » Thu Jan 14, 2016 7:01 pm

Your configuration file must be messed up. At the very end, it says /usr/lib64/mpich/lib after something else is linked. This is interpreted as a file to be linked ("ld" program). It's a directory so you get the error you see.
Kevin W. Thomas
Center for Analysis and Prediction of Storms
University of Oklahoma
kwthomas
 
Posts: 220
Joined: Thu Aug 07, 2008 6:53 pm

Re: Error!!! Geogrid.exe & Metgrid in WRF3.7.1

Postby shahadat » Sun Jan 17, 2016 1:04 am

hello kwthomas,

I hope you are fine. and thanks for your quick replay.
Actually now i'm feeling overwhelming with this installation of WRF. i'm novice in this line. i cant understand, what i will do. Can you tell me actually what i will do now.
Thanks in advance.... and sorry for my broken english.

Shahadat, Bangladesh
shahadat
 
Posts: 9
Joined: Mon Feb 04, 2013 6:00 am

Re: Error!!! Geogrid.exe & Metgrid in WRF3.7.1

Postby msomos » Mon May 09, 2016 9:16 pm

Hi

I wonder if you could solve this. I am having exactly the same problem.

Best,

Marcelo
msomos
 
Posts: 1
Joined: Mon May 09, 2016 9:04 pm

Re: Error!!! Geogrid.exe & Metgrid in WRF3.7.1

Postby rpenc01 » Sun Mar 19, 2017 8:36 pm

Has anyone solved this? I too am trying to configure WRF on Centos 7. Perhaps that is the common factor in the error. I attempted to install WRF and WPS using the instructions at http://www2.mmm.ucar.edu/wrf/OnLineTuto ... .php#STEP3 . Since the necessary libraries are preloaded following these instructions, it should work It does at work (Centos 6.8). It successfully builds WRF. But not WPS. Still getting error:
[log excerpt]
gfortran -o geogrid.exe cio.o wrf_debug.o bitarray_module.o constants_module.o module_stringutil.o geogrid.o gridinfo_module.o hash_module.o interp_module.o list_module.o llxy_module.o misc_definitions_module.o module_debug.o module_map_utils.o output_module.o parallel_module.o process_tile_module.o proc_point_module.o queue_module.o read_geogrid.o smooth_module.o source_data_module.o \
/run/media/pencr/data1/Build_WRF/WPS/../WRFV3/frame/module_driver_constants.o \
/run/media/pencr/data1/Build_WRF/WPS/../WRFV3/frame/pack_utils.o /run/media/pencr/data1/Build_WRF/WPS/../WRFV3/frame/module_machine.o \
/run/media/pencr/data1/Build_WRF/WPS/../WRFV3/frame/module_internal_header_util.o \
-I/run/media/pencr/data1/Build_WRF/WPS/../WRFV3/external/io_netcdf -I/run/media/pencr/data1/Build_WRF/WPS/../WRFV3/external/io_grib_share -I/run/media/pencr/data1/Build_WRF/WPS/../WRFV3/external/io_grib1 -I/run/media/pencr/data1/Build_WRF/WPS/../WRFV3/external/io_int -I/run/media/pencr/data1/Build_WRF/WPS/../WRFV3/inc -I/run/media/pencr/data1/Build_WRF/libraries/netcdf/include \
-L/run/media/pencr/data1/Build_WRF/WPS/../WRFV3/external/io_grib1 -lio_grib1 -L/run/media/pencr/data1/Build_WRF/WPS/../WRFV3/external/io_grib_share -lio_grib_share -L/run/media/pencr/data1/Build_WRF/WPS/../WRFV3/external/io_int -lwrfio_int -L/run/media/pencr/data1/Build_WRF/WPS/../WRFV3/external/io_netcdf -lwrfio_nf -L/run/media/pencr/data1/Build_WRF/libraries/netcdf/lib -lnetcdff -lnetcdf \
/usr/lib64/mpich/lib
/usr/lib64/mpich/lib: file not recognized: Is a directory
collect2: error: ld returned 1 exit status
make[1]: [geogrid.exe] Error 1 (ignored)

Oddly, from the log, it appears that /usr/lib64/mpich/lib was attempted in the linking, yet that is nor specified in the configure.wps, anywhere. I am running the gnu compilers, version 4.8.5. The only executable generated is ungrib.exe. Puzzling and frustrating.

I've read elsewhere adding -lgomp to the WRF_LIB does the trick, but not for me. WRF is in the standard location ../WRFV3.

Any success elsewhere?
rpenc01
 
Posts: 3
Joined: Sun Mar 19, 2017 1:43 am

Re: Error!!! Geogrid.exe & Metgrid in WRF3.7.1

Postby rpenc01 » Sat Mar 25, 2017 7:08 pm

SOLVED: With regard to my post, I tried a solution I found somewhere in old archives, that is:

unset MPI_LIB (environment variable) prior to building WPS.

I installed and configure WRF in smpar mode (single machine, 6 cores, 12 threads i7 processor), followed by the suggested install and build of WPS in serial mode. I unset this environment variable in between building WRF and building WPS. This worked for me.

Custom built PC/Workstation with Asus P6T motherboard
Intel Core i7-970 (6 core)
24 GB of RAM
Centos 7.3 OS software development configuration
Gnu compilers v4.8.5
OpenMPI and Mpich2
rpenc01
 
Posts: 3
Joined: Sun Mar 19, 2017 1:43 am

Re: Error!!! Geogrid.exe & Metgrid in WRF3.7.1

Postby rpenc01 » Tue Mar 28, 2017 12:06 pm

but still WRF-smpar and WPS serial will not compile and build. Only WRF-serial and WPS-serial.

Would like to use all 12 cores by compiling and building WRF-smpar
rpenc01
 
Posts: 3
Joined: Sun Mar 19, 2017 1:43 am


Return to Welcome to the WRF User's Forum

Who is online

Users browsing this forum: No registered users and 3 guests

cron