WRFCHEM: error in wrf.exe SIGSEGV ftuv chem_drive

Any issues with running WRF Chemistry

WRFCHEM: error in wrf.exe SIGSEGV ftuv chem_drive

Postby cran » Tue Jul 25, 2017 4:57 am

Hello,
I'm running wrfchem and until 19th of July I hadn't errors. Since20th of July I have the following rows and wrf.exe die after few minuts:

taskid: 18 hostname: procedurenewtwo
module_io_quilt_old.F 2931 F
Quilting with 1 groups of 0 I/O tasks.
Ntasks in X 6 , ntasks in Y 9
--- WARNING: traj_opt is zero, but num_traj is not zero; setting num_traj to zero.
--- NOTE: sst_update is 0, setting io_form_auxinput4 = 0 and auxinput4_interval = 0 for all domains
--- NOTE: grid_fdda is 0 for domain 1, setting gfdda interval and ending time to 0 for that domain.
--- NOTE: both grid_sfdda and pxlsm_soil_nudge are 0 for domain 1, setting sgfdda interval and ending time to 0 for that domain.
--- NOTE: obs_nudge_opt is 0 for domain 1, setting obs nudging interval and ending time to 0 for that domain.
--- NOTE: bl_pbl_physics /= 4, implies mfshconv must be 0, resetting
Need MYNN PBL for icloud_bl = 1, resetting to 0
--- WARNING: Turning on cu_rad_feedback also requires setting cu_diag== 1
--- NOTE: RRTMG radiation is in use, setting: levsiz=59, alevsiz=12, no_src_types=6
--- NOTE: num_soil_layers has been set to 4
WRF V3.8 MODEL
*************************************
Parent domain
ids,ide,jds,jde 1 140 1 170
ims,ime,jms,jme -4 31 51 83
ips,ipe,jps,jpe 1 24 58 76
*************************************
DYNAMICS OPTION: Eulerian Mass Coordinate
alloc_space_field: domain 1 , 210227612 bytes allocated
med_initialdata_input: calling input_input
INPUT LandUse = "MODIFIED_IGBP_MODIS_NOAH"
LANDUSE TYPE = "MODIFIED_IGBP_MODIS_NOAH" FOUND 33 CATEGORIES 2 SEASONS WATER CATEGORY = 17 SNOW CATEGORY = 15
INITIALIZE THREE Noah LSM RELATED TABLES
*********************************************************************
* PROGRAM:WRF/CHEM V3.8 MODEL
* *
* PLEASE REPORT ANY BUGS TO WRF/CHEM HELP at *
* *
* wrfchemhelp.gsd@noaa.gov *
* *
*********************************************************************
WARNING: RADM2SORG_AQ chemistry option is experimental and not yet fully tested.
We recommend contacting wrfchemhelp for assistance.
call ftuv phot initialization
ftuv_init: calling photo_inti for id = 1
mediation_integrate: med_read_wrf_chem_emissions: Read emissions for time 2017-07-21_12:00:00
mediation_integrate: med_read_wrf_chem_emissions: Open file wrfchemi_d01_2017-07-21_12:00:00
Tile Strategy is not specified. Assuming 1D-Y
WRF TILE 1 IS 1 IE 24 JS 58 JE 76
WRF NUMBER OF TILES = 1
photolysis_driver: called for domain 1
no aerosols initialization yet

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0 0x7F00B102C467
#1 0x7F00B102CAAE
#2 0x7F00AFC8666F
#3 0x31A8BF2 in __module_ftuv_subs_MOD_schu
#4 0x31AD3CB in __module_ftuv_subs_MOD_set_o2_xsect
#5 0x31BE697 in __module_ftuv_subs_MOD_photoin
#6 0x23D237E in __module_ftuv_driver_MOD_photo
#7 0x23DD14C in __module_ftuv_driver_MOD_ftuv_driver
#8 0x1D00BDC in chem_driver_
#9 0x1C17C37 in solve_interface_
#10 0x48848A in __module_integrate_MOD_integrate
#11 0x4088A3 in __module_wrf_top_MOD_wrf_run


please, could you tell me what I can do?
I'm running with dx=12 Km and time_step=40.
I tried decrease my time_step to 20 ... but no success.

I note also at the start of metgrid.log "Processing domain 1 of 1
WRF_DEBUG: NetCDF error: NetCDF: Attribute not found
WRF_DEBUG: NetCDF error in ext_ncd_get_dom_ti.code INTEGER, line 83 Element FLAG_XLAT_M ... " but at the end of file I have "Successful completion of program metgrid.exe", so I think it's right.

I use WRF/CHEM V3.8. Please, let me know if you need other info about my run.

Thanks a lot for the attention,
kind regards
Teresa
cran
 
Posts: 3
Joined: Tue Jul 15, 2008 1:18 pm

Re: WRFCHEM: error in wrf.exe SIGSEGV ftuv chem_drive

Postby Mohammad » Sun Aug 13, 2017 4:00 pm

Hi,

If you are using GFS data, you need to download WPS version 3.9 because GFS data was updated on July 19, 2017.

Regards
Mohammad
 
Posts: 4
Joined: Mon Jun 19, 2017 6:29 am


Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 5 guests