Problems running ripdp_wrfarw on subset wrf region

The RIP4 graphics package.

Problems running ripdp_wrfarw on subset wrf region

Postby bas777 » Tue Aug 16, 2016 11:19 pm

Hi there,

I have wrfout files of a large domain. I want to subset a region of that domain and run RIP on it. Without subsetting, rip runs ripdp_wrfarw fine without any problem, however, when I subset the desired area from wrf domain using nco, ripdp_wrfarw failed. Following is what i did and the error i am getting:

> ncea -d south_north,280,500 -d west_east,130,370 ../data/wrfout_d05_2015-11-01_03:00:00 wrfout_d05_2015-11-01_03:00:00

> ripdp_wrfarw subsetData/anta all data/subsets/wrfout_d05_2015-11-01_03:00:00
Data is recognized as WRF data.

SIMULATION_START_DATE exists, use it as start_date
start_date=2015-11-01_00:00:00
Welcome to your friendly RIPDP (V4.6.7) output file !
Note: RIPDP will process all times encountered.
Found QSNOW variable, set iice = 1
NetCDF error in ripdp_wrfarw. Marker = 53.0000000
NetCDF: Start+count exceeds dimension bound


As mentioned before, if i don't subset wrf domain, then everything goes fine. I would greatly appreciate if anyone could help me to fix it.

Many thanks in advance.

Cheers,
Bas:)
bas777
 
Posts: 1
Joined: Tue Aug 16, 2016 10:58 pm

Re: Problems running ripdp_wrfarw on subset wrf region

Postby dcvz » Tue Feb 21, 2017 2:30 am

You need to set the staggered dimensions, too. Like this:

ncea -d south_north,280,500 -d west_east,130,370 -d south_north_stag,280,500 -d west_east_stag,130,370 ../data/wrfout_d05_2015-11-01_03:00:00 wrfout_d05_2015-11-01_03:00:00

then it should work.

This issue can be debugged by looking at ncdump -h wrfout_d05... and checking the various dimensions.
dcvz
 
Posts: 151
Joined: Tue Apr 15, 2008 12:02 am


Return to RIP4

Who is online

Users browsing this forum: No registered users and 2 guests