Missing date in ARWpost

Discussions related to the use of ARWPost

Re: Missing date in ARWpost

Postby DwyaneChou » Fri Apr 03, 2015 1:49 pm

Excellent answer pal! You did help me a lot!
DwyaneChou
 
Posts: 6
Joined: Mon Dec 29, 2014 10:36 am

Re: Missing date in ARWpost

Postby mollmann » Fri May 08, 2015 2:07 pm

Wow! Thanks, very hepful, see you later, Gabigol.
mollmann
 
Posts: 5
Joined: Mon Jul 15, 2013 10:44 am

Re: Missing date in ARWpost

Postby Sherdon Uy » Fri Aug 19, 2016 6:27 am

Many thanks, gabrielbmw! This certainly helped me. It seems ARWpost has trouble reading multiple wrfout files if the month is terminated in one and continues to the next without the changes you mentioned here.
Sherdon Uy
 
Posts: 3
Joined: Thu Aug 04, 2016 10:20 am

Re: Missing date in ARWpost

Postby felin » Sat Mar 11, 2017 10:26 am

Thank you gabrielbmw!! I have finished my problem!
felin
 
Posts: 13
Joined: Sat Mar 11, 2017 9:30 am

Re: Missing date in ARWpost

Postby felin » Tue Mar 14, 2017 3:54 am

gabrielbmw wrote:Hi,

I'm having the same problem, but on 1980-02-01_00:00:00. But i fixed it
There is a problem when arwpost 3 is looking for the right time. While the program ir looping in time, it does a diference between the loop time and the wanted time, and that diference isn't using "month", so, in my case, when the program get on 1980-01-01_00:00:00, it calculate zero in the diference, broking everytinng. To fix that, change in ./src/module_date_pack.f90 the line 706:
seconds = second + 60*minute + 60*60*hour + 60*60*24*day + 60*60*24*365*century_year
for:
seconds = second + 60*minute + 60*60*hour + 60*60*24*day + 60*60*24*31*month + 60*60*24*365*century_year

copile and run!!! :D


THANKS YOU VERY MUCH
felin
 
Posts: 13
Joined: Sat Mar 11, 2017 9:30 am

Previous

Return to ARWPost

Who is online

Users browsing this forum: No registered users and 1 guest

cron