ARWpost.exe compiling Error

Discussions related to the use of ARWPost

ARWpost.exe compiling Error

Postby jerryleo » Sun Sep 19, 2010 3:06 am

Hi,

The compiler is PGI 10.6

The latest WRF V3.2.1 was compiled without any problem

But I failed to compile ARWpost. It always complained the following error messages

/home/wrf/3.2.1/ARWpost/../WRFV3/frame/module_machine.o: In function `.C3_283':
module_machine.f90:(.data+0x8): undefined reference to `module_driver_constants_'
make: [ARWpost.exe] Error 2 (ignored)

After I commented out the 'use module_driver_constants' in module_machine.F under WRFVE/frame, it's no problem for compiling ARWpost. And It's also no problem for compiling WRF.

I wonder whether if it's safe to comment out 'use module_driver_constants' in module_machine.F under WRFVE/frame?

Or any ideas for compiling ARWpost?

Thanks

Jerry
jerryleo
 
Posts: 7
Joined: Thu Jul 30, 2009 12:26 am

Re: ARWpost.exe compiling Error

Postby twister_9686 » Wed Mar 28, 2012 5:19 pm

Hi Jerry,
How are you? I was wondering if you were able to find a solution for this problem. I am experiencing the same error message when I try to compile ARWpost on a CRAY machine.
I tried your suggestion of commenting out the 'use module_driver_constants' line in module_machine.F, and was able to compile ARWpost. But, as you, I concerned if this is a safe move.
Did you manage to compile ARWpost without having to change module_machine.F?
I'll appreciate your reply.
Thank you.
Fernando
twister_9686
 
Posts: 2
Joined: Mon Apr 28, 2008 8:41 pm

Re: ARWpost.exe compiling Error

Postby Venizeat27 » Wed Oct 16, 2013 8:51 am

Try installing ARWpost 3.0. He worked on my machine CRAY
Venizeat27
 
Posts: 29
Joined: Mon Dec 10, 2012 2:57 pm

ARWpost exe compiling Error

Postby HaroldExeri » Sat Mar 14, 2015 9:35 pm

It's better to try and fix it yourself though, so you'll learn. Try and remove the caps from the filename, also are you compiling with Advanced compile? If so, please post a picture of your settings here.
HaroldExeri
 
Posts: 4
Joined: Thu Dec 18, 2014 12:49 am

Re: ARWpost.exe is not running

Postby paparao.met » Mon Jul 11, 2016 4:59 am

Hi ,

today i given the run >./ARWpost.exe instead of ./ARwpost.exe after that ./ARWpost.exe is not running and it is not shows any error. i opend ls -lh it is showing 0kb size ....can u plz tell me solution ....regarding the ARWpost.exe .....
paparao.met
 
Posts: 1
Joined: Mon Jul 11, 2016 4:49 am

fortran runtime error, for gridinfo_module.f

Postby iamattri » Sun Apr 15, 2018 1:18 am

Hi i am new to WRF model
i have come across this error


my namelist.arwpost looks like this :-


&datetime
start_date = '2017-10-01_00:00:00',
end_date = '2017-10-02_00:00:00',
interval_seconds = 3600,
tacc = 0,
debug_level = 0,
/

&io
input_root_name = './wrfout_d03_2017-10-01_00:00:00'
output_root_name = './wind_d03_210mlevel'
! output_root_name = './wind_06_observation_a_d03_25march'
plot = 'all_list'
fields = 'u10m,v10m,wspd,wdir'
! fields = 'u10,v10,height,pressure,tk,tc'
mercator_defs = .true.
/
split_output = .true.
frames_per_outfile = 2


plot = 'all'
plot = 'list'
plot = 'all_list'
! Below is a list of all available diagnostics
fields = 'u10m,v10m,u,v'
!'height,geopt,theta,tc,tk,td,td2,rh,rh2,umet,vmet,pressure,u10m,v10m,wdir,wspd,wd10,ws10,slp,mcape,mcin,lcl,lfc,cape,cin,dbz,max_dbz,clfr'

&inter
interp_method = 0,
interp_levels = 0.18, 0.19, 0.20, 0.21, 0.24, 0.25, 0.26,
/
extrapolate = .true.

interp_method = 0, ! 0 is model levels, -1 is nice height levels, 1 is user specified pressure/height

interp_levels = 1000.,950.,900.,850.,800.,750.,700.,650.,600.,550.,500.,450.,400.,350.,300.,250.,200.,150.,100.,
interp_levels = 0.25, 0.50, 0.75, 1.00, 2.00, 3.00, 4.00, 5.00, 6.00, 7.00, 8.00, 9.00, 10.0, 11.0, 12.0, 13.0, 14.0, 15.0, 16.0, 17.0, 18.0, 19.0, 20.0,




and the error i am facing is :-



!!!!!!!!!!!!!!!!
ARWpost v3.1
!!!!!!!!!!!!!!!!
At line 94 of file gridinfo_module.f (unit = 10, file = 'namelist.ARWpost')
Fortran runtime error: End of file
iamattri
 
Posts: 1
Joined: Thu Mar 01, 2018 1:17 pm


Return to ARWPost

Who is online

Users browsing this forum: No registered users and 3 guests