ARWpost.exe compiling Error

Discussions related to the use of ARWPost

ARWpost.exe compiling Error

Postby jerryleo » Sun Sep 19, 2010 3:06 am

Hi,

The compiler is PGI 10.6

The latest WRF V3.2.1 was compiled without any problem

But I failed to compile ARWpost. It always complained the following error messages

/home/wrf/3.2.1/ARWpost/../WRFV3/frame/module_machine.o: In function `.C3_283':
module_machine.f90:(.data+0x8): undefined reference to `module_driver_constants_'
make: [ARWpost.exe] Error 2 (ignored)

After I commented out the 'use module_driver_constants' in module_machine.F under WRFVE/frame, it's no problem for compiling ARWpost. And It's also no problem for compiling WRF.

I wonder whether if it's safe to comment out 'use module_driver_constants' in module_machine.F under WRFVE/frame?

Or any ideas for compiling ARWpost?

Thanks

Jerry
jerryleo
 
Posts: 7
Joined: Thu Jul 30, 2009 12:26 am

Re: ARWpost.exe compiling Error

Postby twister_9686 » Wed Mar 28, 2012 5:19 pm

Hi Jerry,
How are you? I was wondering if you were able to find a solution for this problem. I am experiencing the same error message when I try to compile ARWpost on a CRAY machine.
I tried your suggestion of commenting out the 'use module_driver_constants' line in module_machine.F, and was able to compile ARWpost. But, as you, I concerned if this is a safe move.
Did you manage to compile ARWpost without having to change module_machine.F?
I'll appreciate your reply.
Thank you.
Fernando
twister_9686
 
Posts: 2
Joined: Mon Apr 28, 2008 8:41 pm

Re: ARWpost.exe compiling Error

Postby Venizeat27 » Wed Oct 16, 2013 8:51 am

Try installing ARWpost 3.0. He worked on my machine CRAY
Venizeat27
 
Posts: 29
Joined: Mon Dec 10, 2012 2:57 pm

ARWpost exe compiling Error

Postby HaroldExeri » Sat Mar 14, 2015 9:35 pm

It's better to try and fix it yourself though, so you'll learn. Try and remove the caps from the filename, also are you compiling with Advanced compile? If so, please post a picture of your settings here.
HaroldExeri
 
Posts: 4
Joined: Thu Dec 18, 2014 12:49 am

Re: ARWpost.exe is not running

Postby paparao.met » Mon Jul 11, 2016 4:59 am

Hi ,

today i given the run >./ARWpost.exe instead of ./ARwpost.exe after that ./ARWpost.exe is not running and it is not shows any error. i opend ls -lh it is showing 0kb size ....can u plz tell me solution ....regarding the ARWpost.exe .....
paparao.met
 
Posts: 1
Joined: Mon Jul 11, 2016 4:49 am


Return to ARWPost

Who is online

Users browsing this forum: No registered users and 2 guests