Problems with gen_be_stage3 and gen_be_diags.exe

Issues with running 3DVAR.

Problems with gen_be_stage3 and gen_be_diags.exe

Postby Juarez.VO » Wed Apr 08, 2015 9:15 am

Hello everyone.

I'm running a one day simulation at 2km resolution and 1h output, and I want to add data assimilation to verify the changes to the the output, but when I try to generate my own be.dat the following error appears at gen_be_stage3.chi_u.log and gen_be_stage3.t_u.log:

[1] Initialize namelist variables and other scalars.
Computing vertical error statistics for dates 2015032414 to 2015032510
Interval between dates = 1hours.
Number of ensemble members at each time = 1
[2] Process fields for variable chi_u
Processing data for date 2015032414, variable chi_u and member 1
i, j, k dimensions are 629 328 40
Processing data for date 2015032415, variable chi_u and member 1
Processing data for date 2015032416, variable chi_u and member 1
Processing data for date 2015032417, variable chi_u and member 1
Processing data for date 2015032418, variable chi_u and member 1
Processing data for date 2015032419, variable chi_u and member 1
Processing data for date 2015032420, variable chi_u and member 1
Processing data for date 2015032421, variable chi_u and member 1
Processing data for date 2015032422, variable chi_u and member 1
Processing data for date 2015032423, variable chi_u and member 1
Processing data for date 2015032500, variable chi_u and member 1
Processing data for date 2015032501, variable chi_u and member 1
Processing data for date 2015032502, variable chi_u and member 1
Processing data for date 2015032503, variable chi_u and member 1
Processing data for date 2015032504, variable chi_u and member 1
Processing data for date 2015032505, variable chi_u and member 1
Processing data for date 2015032506, variable chi_u and member 1
Processing data for date 2015032507, variable chi_u and member 1
Processing data for date 2015032508, variable chi_u and member 1
Processing data for date 2015032509, variable chi_u and member 1
Processing data for date 2015032510, variable chi_u and member 1
[3] Calculate eigenvectors and eigenvalues for variable chi_u
Calculate eigenvectors and eigenvalues for bin 1 of 1
---------------------------- FATAL ERROR -----------------------
---------------------------- FATAL ERROR -----------------------
Fatal error in file: da_eof_decomposition.inc LINE: 40
Fatal error in file: da_eof_decomposition.inc LINE: 40
Error in decomposition, info = 39
Error in decomposition, info = 39
----------------------------------------------------------------
----------------------------------------------------------------


Any ideas on how to correct it?
Does my timescale have some to do with it?
All the other stages, including the other parts of stage3 and stage4, runs without a problem. The program stops when running gen_be_diags.exe with the following log file:

/clima/juarez/WRF/V3.6/WRFDA//var/scripts/gen_be/gen_be.ksh[280]: ln: write to 1 failed [Erro de entrada/saída]

[1] Gather regression coefficients.

[2] Gather vertical error eigenvectors, eigenvalues.
forrtl: severe (24): end-of-file during read, unit 24, file /clima/juarez/WRF/V3.6/WRFDA/workdir3d/FC_DIR/be5/working/gen_be_stage3.chi_u.dat
Image PC Routine Line Source
gen_be_diags.exe 000000000053B7EE Unknown Unknown Unknown
gen_be_diags.exe 000000000053A286 Unknown Unknown Unknown
gen_be_diags.exe 00000000004EAC12 Unknown Unknown Unknown
gen_be_diags.exe 000000000048F07B Unknown Unknown Unknown
gen_be_diags.exe 000000000048E5E2 Unknown Unknown Unknown
gen_be_diags.exe 00000000004AEDFB Unknown Unknown Unknown
gen_be_diags.exe 000000000046102C Unknown Unknown Unknown
gen_be_diags.exe 000000000047EE20 Unknown Unknown Unknown
gen_be_diags.exe 000000000040901C Unknown Unknown Unknown
libc.so.6 00007FFFEC952C36 Unknown Unknown Unknown
gen_be_diags.exe 0000000000408F19 Unknown Unknown Unknown


Any help will be very appreciated, thank you.
Juarez.VO
 
Posts: 5
Joined: Tue Apr 09, 2013 11:08 am

Re: Problems with gen_be_stage3 and gen_be_diags.exe

Postby marquijw » Sat Apr 25, 2015 12:02 am

Has this been solved? Currently having the same issue.
marquijw
 
Posts: 4
Joined: Fri Jan 31, 2014 5:39 pm

Re: Problems with gen_be_stage3 and gen_be_diags.exe

Postby Juarez.VO » Fri May 01, 2015 7:10 am

Sorry, marquijw, but I haven't found a solution yet. If you find something, please, let me know.
Juarez.VO
 
Posts: 5
Joined: Tue Apr 09, 2013 11:08 am


Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 3 guests