Segfault when running tutorial

Issues with running 3DVAR.

Segfault when running tutorial

Postby xray » Wed Jul 21, 2010 4:31 am

Hi all,

after installing wrfda using ifort/icc 11.1 and openmpi 1.3 (both in serial or dm config), i get errors running the tutorial case. I'm pretty sure I'm running "the good thing", as I follow carrefully the tutorial steps.

When I use the serial version I get something like this ...

Code: Select all
Calculate innovation vector(iv)
Segmentation fault


which seems quite bad :shock: !

And when dm version is used, I usually have some error relative to the BUFR lib. As I use a little_endian machine and a big_endian WRF, I follow carefully the hints in http://www.mmm.ucar.edu/wrf/users/wrfda/Docs/readBufr.htm but that didn't fix the issue.

Code: Select all
 --------------------------- WARNING ---------------------------
 WARNING FROM FILE: <A HREF="http://www.mmm.ucar.edu/people/wrfhelp/wrfvar/code/
 trunk/da_read_obs_bufr.html">da_read_obs_bufr.inc</a>  LINE:     210
 Error   -1 reading PREPBUFR obs file ob.bufr
 ---------------------------------------------------------------


Code: Select all
**************BUFR ARCHIVE LIBRARY ABORT*****************
 BUFRLIB: OPENBF - ERROR READING INPUT FILE CONNECTED TO UNIT  26 WHEN CHECKING
 FOR 'BUFR' IN FIRST 4 BYTES OF RECORD
 **************BUFR ARCHIVE LIBRARY ABORT*****************


I'm lost here :oops: , can someone help me please.

Best regards,
Vivien
xray
 
Posts: 3
Joined: Wed Jul 21, 2010 4:22 am

Re: Segfault when running tutorial

Postby sravan » Tue Sep 07, 2010 1:20 am

Hi
There is one utility CWORDSH which will rebuild the bufr files into WRFVAR supported format.
Install the utility and produce the BUFR files from that and use in var system.
I hope it will go.

Regards
Sravan
sravan
 
Posts: 3
Joined: Fri Sep 03, 2010 5:30 am


Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 4 guests

cron