A question about running WRF-VAR

Issues with running 3DVAR.

A question about running WRF-VAR

Postby buildg » Tue Jun 17, 2008 7:50 am

Hi, all
I ran WRF-Var (Ver. 3.0) using the example data of WRF homepage successfully.
And then, I tried to run WRF-Var using my experimental case.
I made be.dat and ob.ascii by gen_be and obsproc.
However, the running failed like below error message...
What is "wrfvar failed with error 139"?
Could you tell me how to solve the problem?
Thank you!

~/model/WRFV3-Var/var/TESTDATA/con200/run_cpu1/index.html

==================================================================================
06/10/08 19:36:43 <A HREF="2006070812/wrfvar/index.html">da_run_wrfvar</a>
Tue Jun 10 19:36:58 KST 2008 <FONT COLOR="red">wrfvar failed with error 139</FONT>
==================================================================================


~/model/WRFV3-Var/var/TESTDATA/con200/run_cpu1/2006070812/wrfvar/index.html

==================================================================================
<HTML><HEAD><TITLE>expt wrfvar</TITLE></HEAD><BODY><H1>expt wrfvar</H1><PRE>
Tue Jun 10 19:36:43 KST 2008
REL_DIR <A HREF="file:/home/bky/model/WRFV3-Var">/home/bky/model/WRFV3-Var</a>
WRFVAR_DIR <A HREF="file:/home/bky/model/WRFV3-Var">/home/bky/model/WRFV3-Var</a>
DA_BACK_ERRORS /home/bky/model/WRFV3-Var/var/TESTDATA/be/be.dat
OB_DIR <A HREF="file:/home/bky/model/WRFV3-Var/var/TESTDATA/ob">/home/bky/model/WRFV3-Var/var/TESTDATA/ob</a>
RC_DIR <A HREF="file:/home/bky/model/WRFV3-Var/var/TESTDATA/rc">/home/bky/model/WRFV3-Var/var/TESTDATA/rc</a>
FC_DIR <A HREF="file:/home/bky/model/WRFV3-Var/var/TESTDATA/con200/run_cpu1/fc">/home/bky/model/WRFV3-Var/var/TESTDATA/con200/run_cpu1/fc</a>
RUN_DIR <A HREF="file:.">/home/bky/model/WRFV3-Var/var/TESTDATA/con200/run_cpu1/2006070812/wrfvar</a>
WORK_DIR <A HREF="file:working">/home/bky/model/WRFV3-Var/var/TESTDATA/con200/run_cpu1/2006070812/wrfvar/working</a>
DA_ANALYSIS /home/bky/model/WRFV3-Var/var/TESTDATA/con200/run_cpu1/fc/2006070812/wrfinput_d01
DATE 2006070812
WINDOW_START 0
WINDOW_END 0
<A HREF="namelist.input">Namelist.input</a>
/usr/local/mpich/bin/mpirun.ch_p4: line 243: 10557 Segmentation fault (core dumped) "/home/bky/model/WRFV3-Var/var/TESTDATA/con200/run_cpu1/2006070812/wrfvar/working/./da_wrfvar.exe" -p4pg "/home/bky/model/WRFV3-Var/var/TESTDATA/con200/run_cpu1/2006070812/wrfvar/working/PI10501" -p4wd "/home/bky/model/WRFV3-Var/var/TESTDATA/con200/run_cpu1/2006070812/wrfvar/working"
mv: cannot stat `trace/*': No such file or directory
<A HREF="namelist.output">Namelist.output</a>
<A HREF="trace/0.html">PE 0 trace</a>
<A HREF="trace">Other tracing</a>
<A HREF="cost_fn">Cost function</a>
<A HREF="grad_fn">Gradient function</a>
<A HREF="statistics">Statistics</a>
06/10/08 19:36:58 Ended 139
</PRE></BODY></HTML>
==================================================================================
buildg
 
Posts: 6
Joined: Wed Jun 11, 2008 2:09 am

Re: A question about running WRF-VAR

Postby aimee » Fri Jun 20, 2008 8:07 am

Hi all,

unfortunately I cannot answer your question, but I do have a similar problem, only my error number is different, I get error 137.
does anyone know what this means?
rank 0 in job 57 wrf1.nl.meteogroup.net_59934 caused collective abort of all ranks
exit status of rank 0: killed by signal 9


I don't get this error if I use the wrfbdy and wrfinput of the testcase with the ob.ascii of my own case, when only the date in script of the testcase is changed. But as soon as I change the grid point numbers (NL_E_WE, NL_E_SN, NL_DX, NL_DY, NL_E_VERT) towards the settings used in wrf to create wrfinput and wrfbdy, wrfvar crashes again..

I hope someone can help me!

thanks, Aimée


/home/aimee/data/con200/run_cpu1/2008061800/wrfvar/index.html


<HTML><HEAD><TITLE>expt wrfvar</TITLE></HEAD><BODY><H1>expt wrfvar</H1><PRE>
Fri Jun 20 10:26:07 UTC 2008
REL_DIR <A HREF="file:/home/aimee/WRFV3">/home/aimee/WRFV3</a>
WRFVAR_DIR <A HREF="file:/home/aimee/WRFV3/WRFDA">/home/aimee/WRFV3/WRFDA</a>
DA_BACK_ERRORS /home/aimee/data/tutorialv3/be/be.dat
OB_DIR <A HREF="file:/home/aimee/data/tutorialv3/ob">/home/aimee/data/tutorialv3/ob</a>
RC_DIR <A HREF="file:/home/aimee/data/tutorialv3/rc">/home/aimee/data/tutorialv3/rc</a>
FC_DIR <A HREF="file:/home/aimee/data/con200/run_cpu1/fc">/home/aimee/data/con200/run_cpu1/fc</a>
RUN_DIR <A HREF="file:.">/home/aimee/data/con200/run_cpu1/2008061800/wrfvar</a>
WORK_DIR <A HREF="file:working">/home/aimee/data/con200/run_cpu1/2008061800/wrfvar/working</a>
DA_ANALYSIS /home/aimee/data/con200/run_cpu1/fc/2008061800/wrfinput_d01
DATE 2008061800
WINDOW_START 0
WINDOW_END 0
<A HREF="namelist.input">Namelist.input</a>
starting wrf task 0 of 1
rank 0 in job 57 wrf1.nl.meteogroup.net_59934 caused collective abort of all ranks
exit status of rank 0: killed by signal 9
mv: cannot stat `trace/*': No such file or directory
<A HREF="namelist.output">Namelist.output</a>
<A HREF="rsl/rsl.out.0000.html">rsl.out.0000</a>
<A HREF="rsl/rsl.error.0000.html">rsl.error.0000</a>
<A HREF="rsl">Other RSL output</a>
<A HREF="trace/0.html">PE 0 trace</a>
<A HREF="trace">Other tracing</a>
<A HREF="cost_fn">Cost function</a>
<A HREF="grad_fn">Gradient function</a>
<A HREF="statistics">Statistics</a>
06/20/08 10:26:14 Ended 137
</PRE></BODY></HTML>
aimee
 
Posts: 15
Joined: Tue May 20, 2008 9:44 am

Re: A question about running WRF-VAR

Postby hclin » Fri Jun 20, 2008 2:27 pm

What are the grid dimensions (e_we, e_sn, e_vert)?
hclin
 
Posts: 68
Joined: Thu Apr 24, 2008 7:21 pm

Re: A question about running WRF-VAR

Postby aimee » Mon Jun 23, 2008 2:55 am

e_we=284, e_sn=315, e_vert=25, dx&dy=9000.
aimee
 
Posts: 15
Joined: Tue May 20, 2008 9:44 am

Re: A question about running WRF-VAR

Postby buildg » Mon Jun 23, 2008 7:42 am

I found out my error due to just one point data from "ob.ascii" through several tests.
My run was finished successfully after deleting these lines.

FM-12 TEMP 2006-07-08_12:00:00 SFC OBS from NCAR ADP DS464.0 4 47.500 107.000 99999.000 MNP45
-888888.000 -88 200.00 -888888.000 -88 0.200
83200.000 0 100.00 3.087 0 1.10 200.000 0 5.00 1590.000 -5 6.00 292.150 0 2.00 -888888.000 -11 2.00 -888888.000 -11 10.00
83180.000 0 100.00 4.116 0 1.10 170.000 0 5.00 1592.000 -5 6.00 292.250 0 2.00 -888888.000 -11 2.00 -888888.000 -11 10.00
83170.000 0 100.00 4.116 0 1.10 180.000 0 5.00 1593.000 -5 6.00 292.250 0 2.00 -888888.000 -11 2.00 -888888.000 -11 10.00
83150.000 0 100.00 2.058 0 1.10 170.000 0 5.00 1595.000 -5 6.00 292.350 0 2.00 -888888.000 -11 2.00 -888888.000 -11 10.00


Thank you for your help!


Aimée~
Which did you use be.dat file? your own file or default file?
I think you should check your background error file (be.dat)
buildg
 
Posts: 6
Joined: Wed Jun 11, 2008 2:09 am

Re: A question about running WRF-VAR

Postby aimee » Tue Jun 24, 2008 9:48 am

hey buildg

I'm using the default be_file. do you reckon I shouldn't?

ciao, Aimée
aimee
 
Posts: 15
Joined: Tue May 20, 2008 9:44 am

Re: A question about running WRF-VAR

Postby buildg » Tue Jun 24, 2008 9:18 pm

Aimée

I don't know how you can solve your error well...
But I think you should use your own be.dat (e_we=284, e_sn=315, e_vert=25) from "gen_be"
buildg
 
Posts: 6
Joined: Wed Jun 11, 2008 2:09 am

Re: A question about running WRF-VAR

Postby aimee » Thu Jun 26, 2008 6:12 am

Hi all,

I found out more as to why my run is crashing: It seems to be a segmentation fault that is caused by extreme memory usage:
PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
28833 aimee 25 0 2793m 2.3g 3316 R 98 29.4 0:06.97 da_wrfvar.exe

And this is the result:
aimee@wrf1:~/data/con200/run_cpu1/2008061800/wrfvar/working$ ./da_wrfvar.exe
starting wrf task 0 of 1
Segmentation fault

But how come the memory usage is this extreme?

I'm not sure whether this can be caused by the be-file. I thought that the be.dat that is given with the tutorial was a default file that can be used for every case, until you have collected enough data to create your own be-file. am I wrong here?
I suppose I could try to create my own be-file, but I don't know how to do this in the new version. Any suggestions?

I hope someone can help me!
thanks! aimée
aimee
 
Posts: 15
Joined: Tue May 20, 2008 9:44 am

Re: A question about running WRF-VAR

Postby hclin » Thu Jun 26, 2008 11:40 am

In WRFDA_V3, the be.dat in the testdata tar file can ONLY be used in the tutorial case/domain.
You MUST create your own be file for your domain.
You can start by running a few days of WRF forecasts (without data assimilation) to test
generating a be file using gen_be.
Please read
WRFDA/var/scripts/gen_be/gen_be_wrapper.ksh
WRFDA/var/scripts/gen_be/gen_be.ksh
WRFDA/var/scripts/gen_be/gen_be_stage0_wrf.ksh
WRFDA/var/scripts/gen_be/gen_be_stage4_regional.ksh
to get the idea of running gen_be.
hclin
 
Posts: 68
Joined: Thu Apr 24, 2008 7:21 pm

Re: A question about running WRF-VAR

Postby aimee » Thu Jul 10, 2008 2:50 am

thank you very much!
after creating my own be.dat I was able to do a wrf-var run on my own domain!
cheers, aimée
aimee
 
Posts: 15
Joined: Tue May 20, 2008 9:44 am

Next

Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 2 guests

cron