WRF-nesting-urban Physic

Nesting issues in WPS

WRF-nesting-urban Physic

Postby merinconh » Mon May 13, 2019 11:55 pm

I need your help to figure out a problem I'm having while running WRFv3.7.

Actually, I am testing the model using nesting domain, (9km , 3km). The issue is with the execution of wrf.exe.

I guess it's related to the domain settings. I have twweaked max dom: 2, start_time, end_time, e_we and e_sn and dx, by, (from input.wps), history_interval, top_atmosphere etc.

When I run wrf.exe with these values:
sf_urban_physics = 2, 2, 0, # This fails
sf_urban_physics = 0, 2, 0, # This works

I have modified the source code to make use of 3 new urban classes. In case it helps, the diff is attached.

The namelist.input file I'm using is also attached.

Thanks in advance for your help.

Namelist.wps
&share
wrf_core = 'ARW',
max_dom = 2,
start_date = '2009-12-27_00:00:00','2009-12-27_00:00:00','2009-12-27_00:00:00',
end_date = '2009-12-30_00:00:00','2009-12-27_00:00:00','2009-12_27_00:00:00',
interval_seconds = 21600,
io_form_geogrid = 2,
debug_level = 1000,
/

&geogrid
parent_id = 1, 1, 2,
parent_grid_ratio = 1, 3, 3,
i_parent_start = 1, 44, 47,
j_parent_start = 1, 47, 43,
e_we = 100, 43, 118,
e_sn = 106, 40, 106,
geog_data_res = "33classes" ,"33classes", "33classes",
dx = 9000,
dy = 9000,
map_proj = 'mercator',
ref_lat = -23.566,
ref_lon = -46.524,
truelat1 = -23.566,
truelat2 = 23.566,
stand_lon = -46.524,
geog_data_path = '/home/miguelr/geog',


/

&ungrib
out_format = 'WPS',
prefix = 'FILE',
/

&metgrid
fg_name = 'FILE'
io_form_metgrid = 2,
/


namelist.input
~
merinconh
 
Posts: 1
Joined: Tue Jun 21, 2016 1:19 pm

Return to Nesting

Who is online

Users browsing this forum: No registered users and 1 guest