Ungrib/metgrid issues with NAM data from NOMADS

Dataset specific topics involving WPS.

Ungrib/metgrid issues with NAM data from NOMADS

Postby kcking » Thu Jun 25, 2015 7:54 pm

Hi all,

I'm trying to initialize WRF with NAM data from the NOMADS site. It is namanl_218_<DATE>.grb data. When I run ungrib, it seems to be missing soil moisture data because I get zeros in the fields instead of X's. However, I had a look at the grib files and they have this data in them and it matches the dataset numbers in the Vtable.NAM.

The Vtable.NAM says that it is designed for the NAM datasets at ftp://ftpprd.ncep.noaa.gov/pub/data/ncc ... .ccyymmdd/ -- these datasets only cover about the last 3 months or so and I'm attempting to do a run from 2010. When I run metgrid.exe it has many errors (below) and can't seem to find the TT variable and the soil moisture variables. Has anyone run into this before?? Is there some other Vtable out there that I could use for the Nomads NAM files or am I missing something? Thanks so much for any help.

When I try and run metgrid, I get warnings/errors that look like this (and it won't complete):

2015-06-25 16:25:56.068 --- INFORM: Couldn't find SOILT020 at level 200100.000000 to fill level 20.000000 of SOILT.
2015-06-25 16:25:56.069 --- INFORM: Couldn't find SOILT040 at level 200100.000000 to fill level 40.000000 of SOILT.
2015-06-25 16:25:56.069 --- INFORM: Couldn't find SOILT160 at level 200100.000000 to fill level 160.000000 of SOILT.
2015-06-25 16:25:56.069 --- INFORM: Couldn't find SOILT300 at level 200100.000000 to fill level 300.000000 of SOILT.
2015-06-25 16:25:56.069 --- INFORM: Couldn't find SOILT050 at level 200100.000000 to fill level 49.000000 of SOILT.
2015-06-25 16:25:56.069 --- INFORM: Couldn't find SOILT050 at level 200100.000000 to fill level 51.000000 of SOILT.
2015-06-25 16:25:56.069 --- INFORM: Going to create the field SOIL_LEVELS
2015-06-25 16:25:56.069 --- INFORM: Going to create the field PRES
2015-06-25 16:25:56.069 --- INFORM: Couldn't find PSFC at level 200100.000000 to fill level 200100.000000 of PRES.
2015-06-25 16:25:56.069 --- ERROR: The mandatory field TT was not found in any input data.
kcking
 
Posts: 1
Joined: Thu Jun 25, 2015 7:43 pm

Re: Ungrib/metgrid issues with NAM data from NOMADS

Postby ykaore » Wed Jun 27, 2018 8:35 am

I had the exactly same error. Have you found any solution?
ykaore
 
Posts: 9
Joined: Tue Aug 09, 2016 2:56 pm

Re: Ungrib/metgrid issues with NAM data from NOMADS

Postby dcvz » Thu Jun 28, 2018 8:15 pm

The INFORM messages are just (unimportant) information and can be ignored.
The TT not found message really means that there is a missing intermediate file. If you look earlier in the printout, metgrid warns about a missing intermediate file, but it keeps running until it tries to read from the missing file.
dcvz
 
Posts: 176
Joined: Tue Apr 15, 2008 12:02 am


Return to Working with Various Datasets

Who is online

Users browsing this forum: No registered users and 6 guests