geogrid.exe crashes, complaining of memory problems.

Having problems running the WRF Preprocessing Sysmte (WPS)?

geogrid.exe crashes, complaining of memory problems.

Postby kwende » Thu Mar 31, 2016 8:23 pm

Hi,

A couple years ago I had a full end-to-end system using WRF setup. The whole thing was nicely automated. At one point the GRIB files (or their locations) must have changed and as a result I shut down the setup until I found time to go back an figure out what was going on. Two years later I'm finally getting around to doing just that. :shock:

To cut right to the point, I'm getting this crash in geogrid.exe:

Code: Select all
root@vortex:~/Downloads/wrf/WPS# ./geogrid.exe
Parsed 25 entries in GEOGRID.TBL
Processing domain 1 of 2
  Processing XLAT and XLONG
  Processing MAPFAC
  Processing F and E
  Processing ROTANG
  Processing LANDUSEF
  Calculating landmask from LANDUSEF ( WATER =  16 )
  Processing HGT_M
  Processing SOILTEMP
  Processing SOILCTOP
  Processing SCT_DOM
  Processing SOILCBOT
  Processing SCB_DOM
  Processing ALBEDO12M
  Processing GREENFRAC
  Processing LAI12M
  Processing SNOALB
  Processing SLOPECAT
  Processing SLOPECAT
  Processing CON
  Processing VAR
  Processing OA1
  Processing OA2
  Processing OA3
  Processing OA4
  Processing OL1
  Processing OL2
  Processing OL3
  Processing OL4
  Processing VAR_SSO
  Processing LAKE_DEPTH
  Processing URB_PARAM

  Optional fields not processed by geogrid:
    IMPERV (priority=1, resolution='default', path='/home/brush/Downloads/wrf/geo/nlcd2011_imp_ll_9s/')
    CANFRA (priority=1, resolution='default', path='/home/brush/Downloads/wrf/geo/nlcd2011_can_ll_9s/')

Processing domain 2 of 2
Operating system error: Cannot allocate memory
Allocation would exceed memory limit


An abbreviated view at my machine's stats:

Code: Select all
root@vortex:~/Downloads/wrf/WPS# cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 21
model           : 2
model name      : AMD FX(tm)-6300 Six-Core Processor


Code: Select all
oot@vortex:~/Downloads/wrf/WPS# cat /proc/meminfo
MemTotal:        8152028 kB
MemFree:         6489008 kB
MemAvailable:    7792308 kB


So, a six-core processor and eight gigs of RAM.

But for the life of me, I cannot figure out why it's crashing. The only thing I can think of is that I downloaded the wrong product from http://www.ftp.ncep.noaa.gov/data/nccf/com/gfs/prod since this appears to have changed since the last time I set everything up. As an example, when I had it all running years ago my script would download files like this (example file) - gfs.t12z.pgrbf00.grib2. Those don't exist anymore. So instead I'm downloading what I believe to be nearly the equivalent data (example file): gfs.t18z.pgrb2.1p00.f000.

As far as I can tell, the only difference between what I did then and what I'm doing now are the files I'm downloading (but, I think they're still the same 1 degree GRIB files).

Here is my namelist.wps file (I download all the gfs*.grib2 files I showed above into '/home/brush/Downloads/wrf/geo'):

Code: Select all
&share
 wrf_core = 'ARW',
 max_dom = 2,
 start_date = '2016-03-15_18:00:00','2016-03-15_18:00:00',
 end_date   = '2016-03-19_21:00:00','2016-03-19_21:00:00',
 interval_seconds = 10800
 io_form_geogrid = 2,
/

&geogrid
 e_we              =  74
 e_sn              =  70
 geog_data_res     = '10m','2m',
 dx = 30000,
 dy = 30000,
 map_proj = 'lambert',
 ref_lat   =  40.8106,
 ref_lon   = -96.6803,
 truelat1  =  40.8106,
 truelat2  =  40.8106,
 stand_lon = -96.6803,
 geog_data_path = '/home/brush/Downloads/wrf/geo'
/

&ungrib
 out_format = 'WPS',
 prefix = 'FILE',
/

&metgrid
 fg_name = 'FILE'
 io_form_metgrid = 2,
/


Anybody got any thoughts? What am I doing wrong?
kwende
 
Posts: 9
Joined: Tue Jul 29, 2014 12:02 am

Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 2 guests

cron