metgrid.exe problem

Having problems running the WRF Preprocessing Sysmte (WPS)?

metgrid.exe problem

Postby SMinBright » Thu May 30, 2013 3:32 pm

Hi,

I have installed WRFV3.3 on a Linux system. When I get to metgrid.exe, it comes up with the problems below:
Processing domain 1 of 1
*** glibc detected *** ./metgrid.exe: free(): invalid pointer: 0x000000000092a7ce ***
======= Backtrace: =========
/lib64/libc.so.6[0x33fc87230f]
/lib64/libc.so.6(cfree+0x4b)[0x33fc87276b]
./metgrid.exe[0x5894dc]
./metgrid.exe[0x4804a6]
./metgrid.exe[0x454d6d]
./metgrid.exe[0x451c19]
./metgrid.exe[0x40bf6d]
./metgrid.exe[0x4044dc]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x33fc81d994]
./metgrid.exe[0x4043e9]
======= Memory map: ========
00400000-006d3000 r-xp 00000000 9a1:42b38 99659519 /data/mshao/WRF3.3/WPS/metgrid/src/metgrid.exe
008d3000-0092a000 rw-p 002d3000 9a1:42b38 99659519 /data/mshao/WRF3.3/WPS/metgrid/src/metgrid.exe
0092a000-01f56000 rw-p 0092a000 00:00 0
145a2000-191d4000 rw-p 145a2000 00:00 0 [heap]
33fc400000-33fc41c000 r-xp 00000000 08:01 459061 /lib64/ld-2.5.so
33fc61b000-33fc61c000 r--p 0001b000 08:01 459061 /lib64/ld-2.5.so
33fc61c000-33fc61d000 rw-p 0001c000 08:01 459061 /lib64/ld-2.5.so
33fc800000-33fc94e000 r-xp 00000000 08:01 459062 /lib64/libc-2.5.so
33fc94e000-33fcb4d000 ---p 0014e000 08:01 459062 /lib64/libc-2.5.so
33fcb4d000-33fcb51000 r--p 0014d000 08:01 459062 /lib64/libc-2.5.so
33fcb51000-33fcb52000 rw-p 00151000 08:01 459062 /lib64/libc-2.5.so
33fcb52000-33fcb57000 rw-p 33fcb52000 00:00 0
33fcc00000-33fcc82000 r-xp 00000000 08:01 459070 /lib64/libm-2.5.so
33fcc82000-33fce81000 ---p 00082000 08:01 459070 /lib64/libm-2.5.so
33fce81000-33fce82000 r--p 00081000 08:01 459070 /lib64/libm-2.5.so
33fce82000-33fce83000 rw-p 00082000 08:01 459070 /lib64/libm-2.5.so
33fd000000-33fd002000 r-xp 00000000 08:01 459064 /lib64/libdl-2.5.so
33fd002000-33fd202000 ---p 00002000 08:01 459064 /lib64/libdl-2.5.so
33fd202000-33fd203000 r--p 00002000 08:01 459064 /lib64/libdl-2.5.so
33fd203000-33fd204000 rw-p 00003000 08:01 459064 /lib64/libdl-2.5.so
33fd400000-33fd416000 r-xp 00000000 08:01 459065 /lib64/libpthread-2.5.so
33fd416000-33fd615000 ---p 00016000 08:01 459065 /lib64/libpthread-2.5.so
33fd615000-33fd616000 r--p 00015000 08:01 459065 /lib64/libpthread-2.5.so
33fd616000-33fd617000 rw-p 00016000 08:01 459065 /lib64/libpthread-2.5.so
33fd617000-33fd61b000 rw-p 33fd617000 00:00 0
33fdc00000-33fdc07000 r-xp 00000000 08:01 459066 /lib64/librt-2.5.so
33fdc07000-33fde07000 ---p 00007000 08:01 459066 /lib64/librt-2.5.so
33fde07000-33fde08000 r--p 00007000 08:01 459066 /lib64/librt-2.5.so
33fde08000-33fde09000 rw-p 00008000 08:01 459066 /lib64/librt-2.5.so
340b600000-340b60d000 r-xp 00000000 08:01 458965 /lib64/libgcc_s-4.1.2-20080825.so.1
340b60d000-340b80d000 ---p 0000d000 08:01 458965 /lib64/libgcc_s-4.1.2-20080825.so.1
340b80d000-340b80e000 rw-p 0000d000 08:01 458965 /lib64/libgcc_s-4.1.2-20080825.so.1
2b51c72d9000-2b51c72db000 rw-p 2b51c72d9000 00:00 0
2b51c72f6000-2b51c765a000 r-xp 00000000 08:01 10257032 /opt/intel/impi/4.0.3.008/intel64/lib/libmpi.so.4.0
2b51c765a000-2b51c7759000 ---p 00364000 08:01 10257032 /opt/intel/impi/4.0.3.008/intel64/lib/libmpi.so.4.0
2b51c7759000-2b51c7776000 rw-p 00363000 08:01 10257032 /opt/intel/impi/4.0.3.008/intel64/lib/libmpi.so.4.0
2b51c7776000-2b51c77c1000 rw-p 2b51c7776000 00:00 0
2b51c77c1000-2b51c77ee000 r-xp 00000000 08:01 10257067 /opt/intel/impi/4.0.3.008/intel64/lib/libmpigf.so.4.0
2b51c77ee000-2b51c78ee000 ---p 0002d000 08:01 10257067 /opt/intel/impi/4.0.3.008/intel64/lib/libmpigf.so.4.0
2b51c78ee000-2b51c78ef000 rw-p 0002d000 08:01 10257067 /opt/intel/impi/4.0.3.008/intel64/lib/libmpigf.so.4.0
2b51c78ef000-2b51c82f3000 rw-p 2b51c78ef000 00:00 0
2b51c977e000-2b51c9f9e000 rw-p 2b51c977e000 00:00 0
7fff3585a000-7fff358b2000 rw-p 7ffffffa6000 00:00 0 [stack]
7fff35924000-7fff35928000 r-xp 7fff35924000 00:00 0 [vdso]
ffffffffff600000-ffffffffffe00000 ---p 00000000 00:00 0 [vsyscall]
Aborted
Does anybody have can help me to solve this problem?
Thank you
SMinBright
 
Posts: 5
Joined: Thu May 03, 2012 10:15 pm

Re: metgrid.exe problem

Postby Fergui » Wed Oct 05, 2016 12:29 pm

I have the same problem...

Could anybody help us to solve this problem?
Thank you
Fergui
 
Posts: 1
Joined: Wed Oct 05, 2016 8:33 am

Re: metgrid.exe problem

Postby kwthomas » Thu Oct 06, 2016 1:55 pm

That sounds like a program bug. Try upgrading to a newer version of WRF.
Kevin W. Thomas
Center for Analysis and Prediction of Storms
University of Oklahoma
kwthomas
 
Posts: 168
Joined: Thu Aug 07, 2008 6:53 pm


Return to Runtime Problems

Who is online

Users browsing this forum: Google [Bot] and 1 guest