Ungrib - Read error in parse table

Having problems running the WRF Preprocessing Sysmte (WPS)?

Ungrib - Read error in parse table

Postby sveinng » Tue Feb 20, 2018 6:01 pm

Hi

I'm trying to run ungrib but I always run into the same problem. Ungrib starts and gives me the following output immediately:

*** Starting program ungrib.exe ***
Start_date = 2016-03-21_00:00:00 , End_date = 2016-03-21_23:00:00
output format is WPS
Path to intermediate files is ./
ERROR: Read error 1 in PARSE_TABLE.

I have no idea what is wrong, I've moved the Vtable file and changed its permissions but always get the same results? Anyone got an idea of what might be wrong?

Here is the ungrib log file and namelist.wps
2018-02-20 21:27:47.804 --- *** Starting program ungrib.exe ***
2018-02-20 21:27:47.805 --- Start_date = 2016-03-21_00:00:00 , End_date = 2016-03-21_23:00:00
2018-02-20 21:27:47.805 --- Namelist information (coarse domain):
2018-02-20 21:27:47.805 --- START_YEAR = 0
2018-02-20 21:27:47.805 --- START_MONTH = 0
2018-02-20 21:27:47.806 --- START_DAY = 0
2018-02-20 21:27:47.806 --- START_HOUR = 0
2018-02-20 21:27:47.806 --- END_YEAR = 0
2018-02-20 21:27:47.806 --- END_MONTH = 0
2018-02-20 21:27:47.806 --- END_DAY = 0
2018-02-20 21:27:47.806 --- END_HOUR = 0
2018-02-20 21:27:47.806 --- START_DATE = 2016-03-21_00:00:00
2018-02-20 21:27:47.807 --- END_DATE = 2016-03-21_23:00:00
2018-02-20 21:27:47.807 --- INTERVAL_SECONDS = 3600
2018-02-20 21:27:47.807 --- DEBUG_LEVEL = 100
2018-02-20 21:27:47.807 --- /
2018-02-20 21:27:47.807 --- &UNGRIB
2018-02-20 21:27:47.807 --- out_format = WPS
2018-02-20 21:27:47.808 --- ordered_by_date = TRUE
2018-02-20 21:27:47.808 --- prefix = FILE
2018-02-20 21:27:47.808 --- /
2018-02-20 21:27:47.808 --- output format is WPS
2018-02-20 21:27:47.808 --- INFORM: Interval value: 3600 seconds or 1.000000 hours
2018-02-20 21:27:47.808 --- Path to intermediate files is ./
2018-02-20 21:27:47.809 --- INFORM: Linked in png and jpeg libraries for Grib Edition 2
2018-02-20 21:27:47.809 --- INFORM: Reading Grib Edition 2
2018-02-20 21:27:47.809 --- ERROR: Read error 1 in PARSE_TABLE.

&share
wrf_core = 'ARW',
max_dom = 1,
start_date = '2016-03-21_00:00:00',
end_date = '2016-03-21_23:00:00',
interval_seconds = 3600,
io_form_geogrid = 2,
debug_level = 100,
/

&geogrid
parent_id = 1,
parent_grid_ratio = 1,
i_parent_start = 1,
j_parent_start = 1,
e_we = 50,
e_sn = 50,
geog_data_res = '5m',
dx = 9000,
dy = 9000,
map_proj = 'polar',
ref_lat = 64.936,
ref_lon = -18.772,
truelat1 = 64.936,
truelat2 = 90,
stand_lon = -18.772,
geog_data_path = '/media/sveinn/1ABCAE66288E4B60/Forritun/geog',
opt_geogrid_tbl_path = '/media/sveinn/1ABCAE66288E4B60/Vedurvaktin/Endurgreining/ERA5/21.mars'
/

&ungrib
out_format = 'WPS',
prefix = 'FILE',
/

&metgrid
fg_name = 'FILE',
io_form_metgrid = 2,
/
sveinng
 
Posts: 2
Joined: Thu Nov 30, 2017 6:54 pm

Re: Ungrib - Read error in parse table

Postby dcvz » Tue Mar 13, 2018 2:40 am

This error will occur if the Vtable is empty or if there is no '-' character in the first column in any of the rows of the Vtable. If ungrib find a '-' in the first column then it would print out a different error number.
dcvz
 
Posts: 158
Joined: Tue Apr 15, 2008 12:02 am


Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 2 guests

cron