Problem in changing WRF map projection to 'lat-lon'

Having problems running the WRF Preprocessing Sysmte (WPS)?

Problem in changing WRF map projection to 'lat-lon'

Postby twister87 » Sat Oct 27, 2018 5:40 am

Hi all,

I am a very early user of WRF, so apologies in advance if my question will be too easy or too silly for you.

So, I have got WRF (3d real case) perfectly running on my computer with a 'lambert' map projection.

Now, since I would like to investigate a larger geographical domain I want to change the projection from 'lambert' to 'lat-lon'.

Please see below my namelist.wps chunk of code for the 'lat-lon' projection:

Code: Select all
&geogrid
 parent_id = 1,
 parent_grid_ratio = 1,
 i_parent_start = 1,
 j_parent_start = 1,
 e_we = 10,
 e_sn = 10,   
 geog_data_res = '5m',
 dx = 0.25,
 dy = 0.25,             
 map_proj = 'lat-lon',
 ref_lat = 50,
 ref_lon = 0,
 pole_lat = 90,
 pole_lon = 180,
 stand_lon = 0,
 geog_data_path = "${geog_loc}",



and the namelistinput chunk too:

Code: Select all
&domains
time_step                = 60,
time_step_fract_num      = 0,
time_step_fract_den      = 1,
max_dom                  = 1,
e_we                     = 10,
e_sn                     = 10,
e_vert                   = 3, 
p_top_requested          = 5000,
num_metgrid_levels       = 32,
num_metgrid_soil_levels  = 4,
dx                       = 0.25,
dy                       = 0.25,
grid_id                  = 1,
parent_id                = 1,
i_parent_start           = 1,
j_parent_start           = 1,
parent_grid_ratio        = 1,
parent_time_step_ratio   = 1,
feedback                 = 1,
smooth_option            = 0,



I think to have done everything right, but when I run WRF I get the following error:


!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
! Successful completion of ungrib. !
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Processing domain 1 of 1
Processing 2018-10-27_00
FILE
Processing 2018-10-27_06
FILE
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
! Successful completion of metgrid. !
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Note: The following floating-point exceptions are signalling: IEEE_OVERFLOW_FLAG
RUNNING WRF
Sat 27 Oct 10:26:02 BST 2018
starting wrf task 0 of 1
starting wrf task 0 of 3
starting wrf task 1 of 3
starting wrf task 2 of 3

===================================================================================
= BAD TERMINATION OF ONE OF YOUR APPLICATION PROCESSES
= EXIT CODE: 1
= CLEANING UP REMAINING PROCESSES
= YOU CAN IGNORE THE BELOW CLEANUP MESSAGES
===================================================================================


[/code]



And here my rsl.out.0000:

Code: Select all
taskid: 0 hostname: twister
Quilting with   1 groups of   0 I/O tasks.
 Ntasks in X            1 , ntasks in Y            3
--- WARNING: traj_opt is zero, but num_traj is not zero; setting num_traj to zero.
--- NOTE: sst_update is 0, setting io_form_auxinput4 = 0 and auxinput4_interval = 0 for all domains
--- NOTE: grid_fdda is 0 for domain      1, setting gfdda interval and ending time to 0 for that domain.
--- NOTE: both grid_sfdda and pxlsm_soil_nudge are 0 for domain      1, setting sgfdda interval and ending time to 0 for that domain.
--- NOTE: obs_nudge_opt is 0 for domain      1, setting obs nudging interval and ending time to 0 for that domain.
--- NOTE: bl_pbl_physics /= 4, implies mfshconv must be 0, resetting
Need MYNN PBL for icloud_bl = 1, resetting to 0
--- NOTE: RRTMG radiation is not used, setting:  o3input=0 to avoid data pre-processing
*************************************
No physics suite selected.
Physics options will be used directly from the namelist.
*************************************
--- NOTE: num_soil_layers has been set to      4
WRF V3.9.1.1 MODEL
 *************************************
 Parent domain
 ids,ide,jds,jde            1          10           1          10
 ims,ime,jms,jme           -4          15          -4          10
 ips,ipe,jps,jpe            1          10           1           3
 *************************************
DYNAMICS OPTION: Eulerian Mass Coordinate
   alloc_space_field: domain            1 ,               5863268  bytes allocated
  med_initialdata_input: calling input_input
 dx and dy from file        50000.0000       50000.0000
 dx and dy from namelist   0.250000000      0.250000000
  ---- ERROR: DX and DY do not match comparing namelist to the input file
   input_wrf.F: SIZE MISMATCH:  namelist   ide,jde,kde=          10          10           3
   input_wrf.F: SIZE MISMATCH:  input file ide,jde,kde=         200         140          40
  ---- ERROR: Mismatch between namelist and input file dimensions
NOTE:       2 namelist vs input data inconsistencies found.
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE:  <stdin>  LINE:    1142
NOTE:  Please check and reset these options
-------------------------------------------


It looks like the error lies within the input file.

Any suggestion on how to solve this?

Thanks
twister87
 
Posts: 4
Joined: Fri May 25, 2018 4:56 pm

Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 6 guests