WPS v3: undefined references

Installing the WRF Preprocessing System

WPS v3: undefined references

Postby Oscar van der Velde » Wed Apr 16, 2008 8:55 am

Hi,

After figuring out the correct options to compile WRF 3.0 so that it successfully runs parallel, I tried to compile both the preprocessor and the postprocessor without succes. Both give undefined references.
Here is what I did for WPS (and basically same thing for WPPV3):

1. successfully compile WRF 3.
2. clean, and configure. Since I've got NetCDF (/usr/local/), Jasper and the other compression tools installed and their paths in the bashrc, I chose option 6 saying PC Linux i686, Intel compilers, serial (no smpar option), and WITH grib2 (I suppose you get both grib1 and grib2 capabilities then for input).
3. Added -xT option to the configure.wps file for my Core 2 Duo processor but anything else left the same (tried removing #'s for .f90 and F90 but doesn't matter for results). Ensured correct path to WRFV3.
http://www.lightningwizard.com/temp/configure.wps.txt
4. ./compile gives:
http://www.lightningwizard.com/temp/wps_compile2.log

It finds undefined references compiling geogrid.exe, starting with:
module_map_utils.o: In function `map_utils_mp_gausll_':
module_map_utils.f90:(.text+0x4f2): undefined reference to `__svml_acos2'

Note 1: I do not have NCAR graphics installed, and I don't know what -I/data3a/mp/gill/WPS_LIBS/local/include is supposed to be but I do not have it.
Note 2: I'm on Ubuntu but everything runs in my personal folder so that I can do everything without sudo. Using sudo, the important paths would otherwise be stripped from the environment (however, one has to use sudo when installing e.g. netCDF in /usr/local, and it did so without problems)

It seems I have followed all instructions correctly, but this smells like a path issue somewhere nonetheless.
Thanks for your help.

Oscar
Weather Photography | Sprites | Convective Weather Maps
http://www.lightningwizard.com
Oscar van der Velde
 
Posts: 22
Joined: Tue Apr 15, 2008 8:38 pm
Location: Spain

Re: WPS v3: undefined references

Postby Oscar van der Velde » Wed Apr 16, 2008 7:24 pm

Ah, my own fault. Life gets so challenging being a newbie...

I found out 'svml' is a part of Intel compilers and SSE2 things. The -xT optimization for Core 2 Duo processor simply doesn't get accepted well somehow.
So no need to mess around with the configure file, just compile. :lol:

Oscar
Oscar van der Velde
 
Posts: 22
Joined: Tue Apr 15, 2008 8:38 pm
Location: Spain


Return to Installation

Who is online

Users browsing this forum: No registered users and 5 guests