WPS compile problem with ifort - some .exe didnt creat

Installing the WRF Preprocessing System

WPS compile problem with ifort - some .exe didnt creat

Postby negar » Sat Nov 23, 2013 8:12 am

Hi,
I have a problem when I am trying to compile WPS-3 with GRIB2 on Linux2_x86_64 using intel complier and netcdf-3.6.3 .I cant figure out what is wrong. I didn't see some of executable that should be made. (include: plotfmt.exe , plotgrids.exe , height_ukmo.exe )
I installed png-9 , zlib-1.2.8 and jasper-1.900.1.

there is this errors and warning in "compile.log" file:

gcc -c -w -D_UNDERSCORE -DBYTESWAP -DLINUX -DIO_NETCDF -DIO_BINARY -DIO_GRIB1 -D_MPI -DBIT32 -I/data3a/mp/gill/WPS_LIBS/local/include -DUSE_JPEG2000 -DUSE_PNG enc_jpeg2000.c
enc_jpeg2000.c:5:27: fatal error: jasper/jasper.h: No such file or directory
compilation terminated.
make[2]: [enc_jpeg2000.o] Error 1 (ignored)
gcc -c -w -D_UNDERSCORE -DBYTESWAP -DLINUX -DIO_NETCDF -DIO_BINARY -DIO_GRIB1 -D_MPI -DBIT32 -I/data3a/mp/gill/WPS_LIBS/local/include -DUSE_JPEG2000 -DUSE_PNG dec_jpeg2000.c
dec_jpeg2000.c:5:27: fatal error: jasper/jasper.h: No such file or directory
compilation terminated.
make[2]: [dec_jpeg2000.o] Error 1 (ignored)
gcc -c -w -D_UNDERSCORE -DBYTESWAP -DLINUX -DIO_NETCDF -DIO_BINARY -DIO_GRIB1 -D_MPI -DBIT32 -I/data3a/mp/gill/WPS_LIBS/local/include -DUSE_JPEG2000 -DUSE_PNG enc_png.c
enc_png.c:5:17: fatal error: png.h: No such file or directory
compilation terminated.
make[2]: [enc_png.o] Error 1 (ignored)

and:
ar: creating libg2_4.a
ar: enc_jpeg2000.o: No such file or directory
make[2]: [libg2_4.a] Error 1 (ignored)

and:
lpng12 -lpng -lz
ld: cannot find -lg2_4
ld: cannot find -ljasper
ld: cannot find -lpng12
ld: cannot find -lpng
make[1]: [g2print.exe] Error 1 (ignored)
make[1]: Leaving directory `/home/nooshin/WRF/WPS/ungrib/src'

and:
-L/lib -lncarg -lncarg_gks -lncarg_c -L/usr/X11R6/lib -lX11
ld: cannot find -lncarg
ld: cannot find -lncarg_gks
ld: cannot find -lncarg_c
make[1]: [plotfmt.exe] Error 1 (ignored)
make[1]: Leaving directory `/home/nooshin/WRF/WPS/util/src'
if [ -h plotfmt.exe ] ; then \

please help me.
thanks
Last edited by negar on Sun Nov 24, 2013 8:49 am, edited 1 time in total.
negar
 
Posts: 4
Joined: Thu Nov 21, 2013 7:45 pm

Re: WPS compile problem with ifort - some .exe didnt creat

Postby bassline » Thu Jan 09, 2014 4:33 am

Did you compiled the required libraries and linked correctly on your .bashrc file?

If you compiled the libraries with intel compilers, you should compile WPS and WRF with intel compilers... :)
bassline
 
Posts: 55
Joined: Tue Jan 29, 2013 3:25 pm

Re: WPS compile problem with ifort - some .exe didnt creat

Postby aaairsci » Tue Jan 28, 2014 3:24 pm

With respect to plotgrids and plotfmt... I am also not getting those to compile, but based on the output from compile.log... it doesn't even look like they try to compile? I just bumped an older thread regarding this issue.
aaairsci
 
Posts: 3
Joined: Tue Jan 28, 2014 3:19 pm


Return to Installation

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron