Problems compiling WRf with intel compilers

Installing the WRF Preprocessing System

Problems compiling WRf with intel compilers

Postby alen.dioses » Thu Oct 17, 2013 6:21 pm

Hello,

I am trying to compile WRFmodel 3.4.1 using intel compilers (v 13.1.3) and MPICH-1.2.7p1. I had use intel compilers and mpich for BRAMS (Brazilian development on the Atmosferic Modeling System) model and works well.

Frist, I had problems instaling netcdf 4.2 libraries, so I used netcdf 3.6.3 and compile without problems. The configure script works well but the compile script does not. I am sendin the compile.log document.

Information about my PC, I have four processors Intel (R) Xeon (TM) CPU 3.06Hz, CentOS 5.9, uname -a (Linux localhost.localdomain 2.6.18-348.6.1.el5 #1 SMP Tue May 21 15:34:22 EDT 2013 i686 i686 i386 GNU/Linux). Also I use ssh conection without password.

Information about the libraries, I compile the following libraries. ($STUFF=/home/Alen/brams/stuff)


intel compilers were compiler in
/opt/intel

jpeg v6b:
CC=icc ./configure –-prefix=$STUFF
Make
Make install
Make install-lib

zlib-1.1.4
CC=icc ./configure – prefix=$STUFF
Make
Make install

HDF4 v4.2r0
F77=ifort CC=icc ./configure –prefix=$STUFF –with-jpeg=$STUFF –with-zlib=$STUFF
Make
Make install

Mpich-1.2.7p1
RSHCOMMAND=ssh FC=ifort F77=ifort F90=ifort CC=icc CXX=icpc ./configure --prefix=$STUFF
Make
Make install

Netcdf 3.6.3
export F77=ifort
export FC=ifort
export F90=ifort
export CC=icc
export CXX=icpc
./configure --prefix=/usr/local/netcdf
make
make check
make install

Finally, I want to thank you for any advice or help you can give me.
alen.dioses
 
Posts: 1
Joined: Thu Oct 17, 2013 6:11 pm

Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest