Some executables missed in the util/ directory

Installing the WRF Preprocessing System

Some executables missed in the util/ directory

Postby juliosergio » Fri Jul 05, 2013 6:41 pm

Hello!
I'm a WRF beginner, and, as it's advised, I started with the online tutorial. When I got into the WPS part of the tutorial, I learnt that some executables should be present in the util directory, for instance plotgrids.exe, and plotfmt.exe. However they are not. I guess, the tutorial is not up to date, because in the directory appeared some new ncl scripts: plotgrids.ncl and plotfmt_nc.ncl.

Do you have any comments on this?

Thanks,

-Sergio.
juliosergio
 
Posts: 2
Joined: Fri Jul 05, 2013 2:19 pm

Re: Some executables missed in the util/ directory

Postby ddempsey » Tue Sep 24, 2013 6:40 pm

zalta1980's response above unfortunately won't help those of us who can't read Arabic.

However, I'm seeing the same thing repoted by juliosergio--that is, when I compile WPS v.3.5.1, plotgrids.exe and plotfmt.exe are not created, but all other expected *.exe utilities are created successfully.

Moreover, there is not a single reference to either plotgrids or plotfmt in the output of the ./compile command (including no error messages). It's as if the compile command didn't even try to compile these two programs. However, there are commands to compile them in WPS/util/src/Makefile. Did the compile command even consult this Makefile? Other codes in WPS/util/src were compiled--why not plotgrids and plotfmt?

There are plotgrids.F and plotfmt.F files in the WPS/util/src directory, and in in WPS/util there are plotgrids.ncl and plotfmt.ncl NCL scripts (which aren't created by the compilation but instead come with the WPS software package), but the plotgrids.F. and plotfmt.F code isn't converted into *.f90 code files and subsequently compiled and linked.

Since there is a Makefile in WPS/util/src, I naively tried to compile plotgrids and plotfmt individually by running "make plotgrids" and "make plotfmt" in WPS/util/src. This created plogrids.f90 and plotfmt.f90 code files and also created object files for each, but it failed at the linking stage (in my case, trying to link to Intel Fortran libraries; perhaps there wasn't enough information in the Makefile and in environment variables to do this, but identifying the reason is beyond my level of competence).

It would be nice to know what is going on here.
ddempsey
 
Posts: 1
Joined: Tue Sep 24, 2013 6:05 pm

Re: Some executables missed in the util/ directory

Postby pzuidema » Wed Sep 25, 2013 5:37 pm

Interesting. I am having the exact same problem compiling WPS on Yellowstone today.
pzuidema
 
Posts: 1
Joined: Wed Sep 25, 2013 5:32 pm

Re: Some executables missed in the util/ directory

Postby aaairsci » Tue Jan 28, 2014 3:21 pm

I am having this exact problem, and I was wondering if anyone else figured out a solution? I am attempting to go through the WRF tutorial, and I tried using the ncl scripts as given, but plotfmt.ncl will not accept the inputFILE command.

Thanks!
aaairsci
 
Posts: 3
Joined: Tue Jan 28, 2014 3:19 pm

Re: Some executables missed in the util/ directory

Postby bergOpolis » Fri Apr 11, 2014 5:48 am

I am having the same problem.

i.e. no errors in the WPS compile.log, but missing the plotfmt.exe and plotgrids.exe

Have you had any luck solving this?
bergOpolis
 
Posts: 8
Joined: Fri Apr 11, 2014 5:46 am


Return to Installation

Who is online

Users browsing this forum: No registered users and 4 guests