[SOLVED] Building WPS 3.5 on Ubuntu 12.10 x64

Installing the WRF Preprocessing System

Re: [SOLVED] Building WPS 3.5 on Ubuntu 12.10 x64

Postby who_know » Thu Dec 24, 2015 2:51 am

soleiman wrote:for intel compiler this line will help : -liomp5 -lpthread
Just add in WRF_LIB after -lnetcdf

Good luck


This solved my problems with ifort.

Thanks very much.
who_know
 
Posts: 1
Joined: Wed Dec 23, 2015 11:55 pm

Re: Building WPS 3.5 on Ubuntu 12.10 x64

Postby whatnoyeah » Thu Dec 01, 2016 6:45 am

giaaan wrote:Hi,
I had the same problem on Centos 6.4 (64 bit) with gcc+gfortran, with "smpar" option on WRF & "serial" option on WPS. The very simple solution is to add "-lgomp" to the WRF_LIB variable in file configure.wps (just append it after -lnetcdf).
As the latter is overwritten in case of re-configuration you may want to alter the arch/configure.defaults.

I don't think the issue depends on netcdf. On the contrary I suppose the problem arises because metgrid & geogrid are linked to wrf lib which in turns depends on openmp library (if "smpar" is selected). So, even if openmp is not directly needed by metgrid & geogrid, libgomp has to be linked in any case.

Hope it helps
Gianluca


IT HELPS!!!!
THANKS A LOT!!!
whatnoyeah
 
Posts: 1
Joined: Thu Dec 01, 2016 6:43 am

Previous

Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest