WPS, Enter selection [1-0] , Why this problem

Installing the WRF Preprocessing System

WPS, Enter selection [1-0] , Why this problem

Postby saravan » Thu Nov 01, 2018 2:15 am

Hi

Power8 IBM HPC facility. I am trying to install WRF and WPS based on this tutorials:
http://home.chpc.utah.edu/~u0631741/wrf ... _Sfire.pdf

I have no issue in WRFV3 , Whereas I encountered the following issue, could you shed light on this issue,

[Guest@it02-r2-ln-02:wrf-fire] pwd
/home/Guest/wps/wrf-fire
[Guest@it02-r2-ln-02:wrf-fire]
[Guest@it02-r2-ln-02:wrf-fire] ls
doc license.txt other README.txt standalone WPS wps.csh wrfv2_fire WRFV3
[Guest@it02-r2-ln-02:wrf-fire] pwd
/home/Guest/wps/wrf-fire
[Guest@it02-r2-ln-02:wrf-fire]
[Guest@it02-r2-ln-02:wrf-fire] ls
doc license.txt other README.txt standalone WPS wps.csh wrfv2_fire WRFV3
[Guest@it02-r2-ln-02:wrf-fire] cd wps
bash: cd: wps: No such file or directory
[Guest@it02-r2-ln-02:wrf-fire] cd WPS/
[Guest@it02-r2-ln-02:WPS] ls
arch co_meadow_creek configure geogrid metgrid namelist.wps.all_options namelist.wps.global netcdf_links ungrib
clean compile configure.wps.backup link_grib.csh namelist.wps namelist.wps.fire namelist.wps.nmm README util
[Guest@it02-r2-ln-02:WPS] ./configure -os Linux
** WARNING: No path to NETCDF and environment variable NETCDF not set.
** would you like me to try to fix? [y]
y
Enter full path to NetCDF include directory on your system
/apps/netcdf/4.6.1/include
Enter full path to NetCDF library directory on your system
/apps/netcdf/4.6.1/lib
created new ./netcdf_links directory
total 0
lrwxrwxrwx 1 spr proy-001 26 Nov 1 01:02 include -> /apps/netcdf/4.6.1/include/
lrwxrwxrwx 1 spr proy-001 22 Nov 1 01:02 lib -> /apps/netcdf/4.6.1/lib/
Will use NETCDF in dir: /home/Guest/wps/wrf-fire/WPS/netcdf_links
$JASPERLIB or $JASPERINC not found in environment, configuring to build without grib2 I/O...
$GEOTIFF or $LIBTIFF not found in environment, configuring to build without GeoTIFF I/O...
------------------------------------------------------------------------
Please select from among the following supported platforms.
Enter selection [1-0] :

why It is not showing those 1-31 options for the case of WPS installation, whereas It does show the 1-31 option during my successful WRFV3 installation.

thanks

SP
saravan
 
Posts: 3
Joined: Wed Oct 31, 2018 11:52 pm

Re: WPS, Enter selection [1-0] , Why this problem

Postby kwthomas » Thu Nov 01, 2018 4:52 pm

Hi...

Run "./configure" without "-os Linux". According to "configure", "-os Linux" is for cross-compiling, which means
compiling on one hardware type for some totally different hardware type. On most systems, this isn't necessary.

"configure" itself is good at giving you the right options for your system.
Kevin W. Thomas
Center for Analysis and Prediction of Storms
University of Oklahoma
kwthomas
 
Posts: 249
Joined: Thu Aug 07, 2008 6:53 pm

Re: WPS, Enter selection [1-0] , Why this problem

Postby saravan » Thu Nov 01, 2018 7:59 pm

Hi Thomas,

Well, I tried ./configure

It did gave the same error

"Enter selection [1-0]" .

So I see that keeping "-os Linux" doesn't bother much on solving this issue.

Any other suggestions please.

SP
saravan
 
Posts: 3
Joined: Wed Oct 31, 2018 11:52 pm

Re: WPS, Enter selection [1-0] , Why this problem

Postby kwthomas » Fri Nov 02, 2018 3:35 pm

Hi...

You have a system that WRF's "configure" software knows nothing about.

Please give me the following:

o WRF version being used.
o Output of "uname -a" and "uname -m".
o Compiler you are using.

Hopefully, that will be enough so I can give you code changes to make "configure" work.
Kevin W. Thomas
Center for Analysis and Prediction of Storms
University of Oklahoma
kwthomas
 
Posts: 249
Joined: Thu Aug 07, 2008 6:53 pm

Re: WPS, Enter selection [1-0] , Why this problem

Postby saravan » Fri Nov 02, 2018 9:28 pm

1) WRF Model Version 3.4 (April 6, 2012) http://wrf-model.org/users/users.php
Note : I downloaded this "git clone git://github.com/jbeezley/wrf-fire.git" from this tutorial, ":http://home.chpc.utah.edu/~u0631741/wrf-sfire/Compiling_WRF_Sfire.pdf"


Here I encountered the following issues

    [Guest@it01-r4-ln-01:WRFV3] ls
    arch compile_em_real.log dyn_em inc README.DA README_test_cases share
    chem configure dyn_exp main README.io_config README.windturbine test
    clean configure_auto dyn_nmm Makefile README.NMM Registry tools
    compile configure.wrf.backup external phys README.rsl_output run
    compile_em_fire.log configure.wrf.cheyenne frame README README.SSIB running_wrf_on_cheyenne.txt
    [Guest@it01-r4-ln-01:WRFV3]
    [Guest@it01-r4-ln-01:WRFV3]
    [Guest@it01-r4-ln-01:WRFV3] ./configure -os Linux
    checking for perl5... no
    checking for perl... found /usr/bin/perl (perl)
    ** WARNING: No path to NETCDF and environment variable NETCDF not set.
    ** would you like me to try to fix? [y]
    y
    Enter full path to NetCDF include directory on your system
    /apps/netcdf/4.6.1/include
    Enter full path to NetCDF library directory on your system
    /apps/netcdf/4.6.1/lib
    created new ./netcdf_links directory
    total 0
    lrwxrwxrwx 1 Guest proy-001 26 Nov 2 19:40 include -> /apps/netcdf/4.6.1/include/
    lrwxrwxrwx 1 Guest proy-001 22 Nov 2 19:40 lib -> /apps/netcdf/4.6.1/lib/
    Will use NETCDF in dir: /home/Guest/wps/wrf-fire/WRFV3/netcdf_links
    PHDF5 not set in environment. Will configure WRF for use without.
    ./configure: WRF operating system set to "Linux" via environment variable $WRF_OS
    $JASPERLIB or $JASPERINC not found in environment, configuring to build without grib2 I/O...
    ------------------------------------------------------------------------
    Please select from among the following supported platforms.

    1. Linux i486 i586 i686, NEC SX sxf90 sxcc (serial)
    2. Linux i486 i586 i686, NEC SX sxf90 sxcc (smpar)
    3. Linux i486 i586 i686, NEC SX sxf90 sxcc (dmpar)
    4. Linux i486 i586 i686, NEC SX sxf90 sxcc (dm+sm)
    5. Linux i486 i586 i686, gfortran compiler with gcc (serial)
    6. Linux i486 i586 i686, gfortran compiler with gcc (smpar)
    7. Linux i486 i586 i686, gfortran compiler with gcc (dmpar)
    8. Linux i486 i586 i686, gfortran compiler with gcc (dm+sm)
    9. Linux i486 i586 i686, g95 compiler with gcc (serial)
    10. Linux i486 i586 i686, g95 compiler with gcc (dmpar)
    11. Linux x86_64, PGI compiler with pgcc (serial)
    12. Linux x86_64, PGI compiler with pgcc (smpar)
    13. Linux x86_64, PGI compiler with pgcc (dmpar)
    14. Linux x86_64, PGI compiler with pgcc (dm+sm)
    15. Linux x86_64 i486 i586 i686, ifort compiler with icc (serial)
    16. Linux x86_64 i486 i586 i686, ifort compiler with icc (smpar)
    17. Linux x86_64 i486 i586 i686, ifort compiler with icc (dmpar)
    18. Linux x86_64 i486 i586 i686, ifort compiler with icc (dm+sm)
    19. ia64 Linux ifort compiler with icc 9.x,10.x (serial)
    20. ia64 Linux ifort compiler with icc 9.x,10.x (smpar)
    21. ia64 Linux ifort compiler with icc 9.x,10.x (dmpar)
    22. ia64 Linux ifort compiler with icc 9.x,10.x (dm+sm)
    23. x86_64 Linux, gfortran compiler with gcc (serial)
    24. x86_64 Linux, gfortran compiler with gcc (smpar)
    25. x86_64 Linux, gfortran compiler with gcc (dmpar)
    26. x86_64 Linux, gfortran compiler with gcc (dm+sm)
    27. Linux ppc64 BG /L blxlf compiler with blxlc (dmpar)
    28. Linux ppc64 BG /P xlf compiler with xlc (smpar)
    29. Linux ppc64 BG /P xlf compiler with xlc (dmpar)
    30. Linux ppc64 BG /P xlf compiler with xlc (dm+sm)
    31. Linux ppc64 IBM Blade Server xlf compiler with xlc (dmpar)

    Enter selection [1-31] :

    Enter selection [1-31] : 31
    ------------------------------------------------------------------------
    Compile for nesting? (1=basic, 2=preset moves, 3=vortex following) [default 1]: 3

    Configuration successful. To build the model type compile .
    ------------------------------------------------------------------------
    testing for MPI_Comm_f2c and MPI_Comm_c2f
    MPI_Comm_f2c and MPI_Comm_c2f are not supported
    testing for fseeko and fseeko64
    fseeko64 is supported
    ------------------------------------------------------------------------

    # Settings for Linux ppc64 IBM Blade Server xlf compiler with xlc (dmpar)
    # provided by Luis C. Cana Cascallar for IBM JS21 blade server, May 2009
    #
    DMPARALLEL = 1
    OMPCPP = # not supported
    OMP = # not supported
    OMPCC = # not supported
    SFC = xlf90_r -q64
    SCC = xlc_r -q64
    CCOMP = xlc_r -q64
    DM_FC = mpif90 -q64
    DM_CC = mpicc -q64 -DMPI2_SUPPORT -DFSEEKO64_OK
    FC = $(DM_FC)
    CC = $(DM_CC) -DFSEEKO64_OK
    LD = $(FC)
    RWORDSIZE = $(NATIVE_RWORDSIZE)
    PROMOTION = -qrealsize=$(RWORDSIZE) -qintsize=4
    # If system has even more processors, set VERY_LARGE_MAXPROC to that number
    ARCH_LOCAL = -DMOVE_NL_OUTSIDE_MODULE_CONFIGURE -DNONSTANDARD_SYSTEM_SUBR -DLANDREAD_STUB -DVERY_LARGE_MAXPROC=36768
    CFLAGS_LOCAL = -DNOUNDERSCORE -DLANDREAD_STUB
    LDFLAGS_LOCAL =
    CPLUSPLUSLIB = -lC
    ESMF_LDFLAG = $(CPLUSPLUSLIB)
    FCOPTIM = -O3 -qtune=ppc970 -qarch=ppc970
    FCNOOPT = -qnoopt
    FCDEBUG = # -g $(FCNOOPT) -qfullpath
    FORMAT_FIXED = -qfixed
    FORMAT_FREE = -qfree=f90
    FCSUFFIX = -qsuffix=f=f90
    BYTESWAPIO =
    FCBASEOPTS_NO_G = -w -qspill=20000 -qmaxmem=32767 $(FORMAT_FREE) $(BYTESWAPIO) #-qflttrap=zerodivide:invalid:enable -qsigtrap
    FCBASEOPTS = $(FCBASEOPTS_NO_G) $(FCDEBUG)
    MODULE_SRCH_FLAG =
    TRADFLAG =
    # this might be different on different systems but we want the xlf version of cpp, not Linux
    CPP = /opt/ibmcmp/xlf/11.1/exe/cpp -C -P
    AR = ar
    ARFLAGS = ru
    M4 = m4 -B 14000
    RANLIB = ranlib
    CC_TOOLS = xlc -q64
    ###########################################################
    ######################
    # POSTAMBLE

    FGREP = fgrep -iq

    ARCHFLAGS = $(COREDEFS) -DIWORDSIZE=$(IWORDSIZE) -DDWORDSIZE=$(DWORDSIZE) -DRWORDSIZE=$(RWORDSIZE) -DLWORDSIZE=$(LWORDSIZE) \
    $(ARCH_LOCAL) \
    $(DA_ARCHFLAGS) \
    -DDM_PARALLEL \
    \
    -DNETCDF \
    \
    \
    \
    \
    \
    \
    \
    -DMOVE_NESTS -DVORTEX_CENTER \
    -DUSE_ALLOCATABLES \
    -DGRIB1 \
    -DINTIO \
    -DLIMIT_ARGS \
    -DCONFIG_BUF_LEN=$(CONFIG_BUF_LEN) \
    -DMAX_DOMAINS_F=$(MAX_DOMAINS) \
    -DMAX_HISTORY=$(MAX_HISTORY) \
    -DNMM_NEST=$(WRF_NMM_NEST)
    CFLAGS = $(CFLAGS_LOCAL) -DDM_PARALLEL \
    -DMAX_HISTORY=$(MAX_HISTORY)
    FCFLAGS = $(FCOPTIM) $(FCBASEOPTS)
    ESMF_LIB_FLAGS =
    # ESMF 5 -- these are defined in esmf.mk, included above
    ESMF_IO_LIB = -L$(WRF_SRC_ROOT_DIR)/external/esmf_time_f90 -lesmf_time
    ESMF_IO_LIB_EXT = -L$(WRF_SRC_ROOT_DIR)/external/esmf_time_f90 -lesmf_time
    INCLUDE_MODULES = $(MODULE_SRCH_FLAG) \
    $(ESMF_MOD_INC) $(ESMF_LIB_FLAGS) \
    -I$(WRF_SRC_ROOT_DIR)/main \
    -I$(WRF_SRC_ROOT_DIR)/external/io_netcdf \
    -I$(WRF_SRC_ROOT_DIR)/external/io_int \
    -I$(WRF_SRC_ROOT_DIR)/frame \
    -I$(WRF_SRC_ROOT_DIR)/share \
    -I$(WRF_SRC_ROOT_DIR)/phys \
    -I$(WRF_SRC_ROOT_DIR)/chem -I$(WRF_SRC_ROOT_DIR)/inc \
    -I$(NETCDFPATH)/include \

    REGISTRY = Registry

    LIB_BUNDLED = \
    $(WRF_SRC_ROOT_DIR)/external/fftpack/fftpack5/libfftpack.a \
    $(WRF_SRC_ROOT_DIR)/external/io_grib1/libio_grib1.a \
    $(WRF_SRC_ROOT_DIR)/external/io_grib_share/libio_grib_share.a \
    $(WRF_SRC_ROOT_DIR)/external/io_int/libwrfio_int.a \
    $(ESMF_IO_LIB) \
    $(WRF_SRC_ROOT_DIR)/external/RSL_LITE/librsl_lite.a \
    $(WRF_SRC_ROOT_DIR)/frame/module_internal_header_util.o \
    $(WRF_SRC_ROOT_DIR)/frame/pack_utils.o

    LIB_EXTERNAL = \
    -L$(WRF_SRC_ROOT_DIR)/external/io_netcdf -lwrfio_nf -L/home/Guest/wps/wrf-fire/WRFV3/netcdf_links/lib -lnetcdf

    LIB = $(LIB_BUNDLED) $(LIB_EXTERNAL) $(LIB_LOCAL) $(WRFIO_NETCDF_LINKOPTS)
    LDFLAGS = $(OMP) $(FCFLAGS) $(LDFLAGS_LOCAL)
    ENVCOMPDEFS =
    WRF_CHEM = 0
    CPPFLAGS = $(ARCHFLAGS) $(ENVCOMPDEFS) -I$(LIBINCLUDE) $(TRADFLAG)
    NETCDFPATH = /home/Guest/wps/wrf-fire/WRFV3/netcdf_links
    PNETCDFPATH =

    bundled: wrf_ioapi_includes wrfio_grib_share wrfio_grib1 wrfio_int esmf_time fftpack
    external: wrfio_nf $(WRF_SRC_ROOT_DIR)/external/RSL_LITE/librsl_lite.a gen_comms_rsllite module_dm_rsllite $(ESMF_TARGET)

    ######################
    ------------------------------------------------------------------------
    Settings listed above are written to configure.wrf.
    If you wish to change settings, please edit that file.
    If you wish to change the default options, edit the file:
    arch/configure_new.defaults
    grep: /home/Guest/wps/wrf-fire/WRFV3/netcdf_links/include/netcdf.inc: No such file or directory
    NetCDF users note:
    This installation of NetCDF supports large file support. To enable large file
    support in NetCDF, set the environment variable WRFIO_NCD_LARGE_FILE_SUPPORT
    to 1 and run configure again. Set to any other value to avoid this message.


    Testing for NetCDF, C and Fortran compiler

    This installation NetCDF is 64-bit 64-bit
    C compiler is 64-bit 64-bit
    Fortran compiler is 64-bit 64-bit
    It will build in 64-bit 64-bit

    [Guest@it01-r4-ln-01:WRFV3]


    Enter selection [1-31] : 31
    ------------------------------------------------------------------------
    Compile for nesting? (1=basic, 2=preset moves, 3=vortex following) [default 1]: 3

    Configuration successful. To build the model type compile .
    ------------------------------------------------------------------------
    testing for MPI_Comm_f2c and MPI_Comm_c2f
    MPI_Comm_f2c and MPI_Comm_c2f are not supported
    testing for fseeko and fseeko64
    fseeko64 is supported
    ------------------------------------------------------------------------

    # Settings for Linux ppc64 IBM Blade Server xlf compiler with xlc (dmpar)
    # provided by Luis C. Cana Cascallar for IBM JS21 blade server, May 2009
    #
    DMPARALLEL = 1
    OMPCPP = # not supported
    OMP = # not supported
    OMPCC = # not supported
    SFC = xlf90_r -q64
    SCC = xlc_r -q64
    CCOMP = xlc_r -q64
    DM_FC = mpif90 -q64
    DM_CC = mpicc -q64 -DMPI2_SUPPORT -DFSEEKO64_OK
    FC = $(DM_FC)
    CC = $(DM_CC) -DFSEEKO64_OK
    LD = $(FC)
    RWORDSIZE = $(NATIVE_RWORDSIZE)
    PROMOTION = -qrealsize=$(RWORDSIZE) -qintsize=4
    # If system has even more processors, set VERY_LARGE_MAXPROC to that number
    ARCH_LOCAL = -DMOVE_NL_OUTSIDE_MODULE_CONFIGURE -DNONSTANDARD_SYSTEM_SUBR -DLANDREAD_STUB -DVERY_LARGE_MAXPROC=36768
    CFLAGS_LOCAL = -DNOUNDERSCORE -DLANDREAD_STUB
    LDFLAGS_LOCAL =
    CPLUSPLUSLIB = -lC
    ESMF_LDFLAG = $(CPLUSPLUSLIB)
    FCOPTIM = -O3 -qtune=ppc970 -qarch=ppc970
    FCNOOPT = -qnoopt
    FCDEBUG = # -g $(FCNOOPT) -qfullpath
    FORMAT_FIXED = -qfixed
    FORMAT_FREE = -qfree=f90
    FCSUFFIX = -qsuffix=f=f90
    BYTESWAPIO =
    FCBASEOPTS_NO_G = -w -qspill=20000 -qmaxmem=32767 $(FORMAT_FREE) $(BYTESWAPIO) #-qflttrap=zerodivide:invalid:enable -qsigtrap
    FCBASEOPTS = $(FCBASEOPTS_NO_G) $(FCDEBUG)
    MODULE_SRCH_FLAG =
    TRADFLAG =
    # this might be different on different systems but we want the xlf version of cpp, not Linux
    CPP = /opt/ibmcmp/xlf/11.1/exe/cpp -C -P
    AR = ar
    ARFLAGS = ru
    M4 = m4 -B 14000
    RANLIB = ranlib
    CC_TOOLS = xlc -q64
    ###########################################################
    ######################
    # POSTAMBLE

    FGREP = fgrep -iq

    ARCHFLAGS = $(COREDEFS) -DIWORDSIZE=$(IWORDSIZE) -DDWORDSIZE=$(DWORDSIZE) -DRWORDSIZE=$(RWORDSIZE) -DLWORDSIZE=$(LWORDSIZE) \
    $(ARCH_LOCAL) \
    $(DA_ARCHFLAGS) \
    -DDM_PARALLEL \
    \
    -DNETCDF \
    \
    \
    \
    \
    \
    \
    \
    -DMOVE_NESTS -DVORTEX_CENTER \
    -DUSE_ALLOCATABLES \
    -DGRIB1 \
    -DINTIO \
    -DLIMIT_ARGS \
    -DCONFIG_BUF_LEN=$(CONFIG_BUF_LEN) \
    -DMAX_DOMAINS_F=$(MAX_DOMAINS) \
    -DMAX_HISTORY=$(MAX_HISTORY) \
    -DNMM_NEST=$(WRF_NMM_NEST)
    CFLAGS = $(CFLAGS_LOCAL) -DDM_PARALLEL \
    -DMAX_HISTORY=$(MAX_HISTORY)
    FCFLAGS = $(FCOPTIM) $(FCBASEOPTS)
    ESMF_LIB_FLAGS =
    # ESMF 5 -- these are defined in esmf.mk, included above
    ESMF_IO_LIB = -L$(WRF_SRC_ROOT_DIR)/external/esmf_time_f90 -lesmf_time
    ESMF_IO_LIB_EXT = -L$(WRF_SRC_ROOT_DIR)/external/esmf_time_f90 -lesmf_time
    INCLUDE_MODULES = $(MODULE_SRCH_FLAG) \
    $(ESMF_MOD_INC) $(ESMF_LIB_FLAGS) \
    -I$(WRF_SRC_ROOT_DIR)/main \
    -I$(WRF_SRC_ROOT_DIR)/external/io_netcdf \
    -I$(WRF_SRC_ROOT_DIR)/external/io_int \
    -I$(WRF_SRC_ROOT_DIR)/frame \
    -I$(WRF_SRC_ROOT_DIR)/share \
    -I$(WRF_SRC_ROOT_DIR)/phys \
    -I$(WRF_SRC_ROOT_DIR)/chem -I$(WRF_SRC_ROOT_DIR)/inc \
    -I$(NETCDFPATH)/include \

    REGISTRY = Registry

    LIB_BUNDLED = \
    $(WRF_SRC_ROOT_DIR)/external/fftpack/fftpack5/libfftpack.a \
    $(WRF_SRC_ROOT_DIR)/external/io_grib1/libio_grib1.a \
    $(WRF_SRC_ROOT_DIR)/external/io_grib_share/libio_grib_share.a \
    $(WRF_SRC_ROOT_DIR)/external/io_int/libwrfio_int.a \
    $(ESMF_IO_LIB) \
    $(WRF_SRC_ROOT_DIR)/external/RSL_LITE/librsl_lite.a \
    $(WRF_SRC_ROOT_DIR)/frame/module_internal_header_util.o \
    $(WRF_SRC_ROOT_DIR)/frame/pack_utils.o

    LIB_EXTERNAL = \
    -L$(WRF_SRC_ROOT_DIR)/external/io_netcdf -lwrfio_nf -L/home/Guest/wps/wrf-fire/WRFV3/netcdf_links/lib -lnetcdf

    LIB = $(LIB_BUNDLED) $(LIB_EXTERNAL) $(LIB_LOCAL) $(WRFIO_NETCDF_LINKOPTS)
    LDFLAGS = $(OMP) $(FCFLAGS) $(LDFLAGS_LOCAL)
    ENVCOMPDEFS =
    WRF_CHEM = 0
    CPPFLAGS = $(ARCHFLAGS) $(ENVCOMPDEFS) -I$(LIBINCLUDE) $(TRADFLAG)
    NETCDFPATH = /home/Guest/wps/wrf-fire/WRFV3/netcdf_links
    PNETCDFPATH =

    bundled: wrf_ioapi_includes wrfio_grib_share wrfio_grib1 wrfio_int esmf_time fftpack
    external: wrfio_nf $(WRF_SRC_ROOT_DIR)/external/RSL_LITE/librsl_lite.a gen_comms_rsllite module_dm_rsllite $(ESMF_TARGET)

    ######################
    ------------------------------------------------------------------------
    Settings listed above are written to configure.wrf.
    If you wish to change settings, please edit that file.
    If you wish to change the default options, edit the file:
    arch/configure_new.defaults
    grep: /home/Guest/wps/wrf-fire/WRFV3/netcdf_links/include/netcdf.inc: No such file or directory
    NetCDF users note:
    This installation of NetCDF supports large file support. To enable large file
    support in NetCDF, set the environment variable WRFIO_NCD_LARGE_FILE_SUPPORT
    to 1 and run configure again. Set to any other value to avoid this message.


    Testing for NetCDF, C and Fortran compiler

    This installation NetCDF is 64-bit 64-bit
    C compiler is 64-bit 64-bit
    Fortran compiler is 64-bit 64-bit
    It will build in 64-bit 64-bit

    [Guest@it01-r4-ln-01:WRFV3]

    [Guest@it01-r4-ln-01:WRFV3] less configure.wrf
    [Guest@it01-r4-ln-01:WRFV3] ./compile em_real >& compile_em_real.log &
    [4] 122678
    [Guest@it01-r4-ln-01:WRFV3] ./compile em_fire >& compile_em_fire.log &
    [5] 130856
    [4] Done ./compile em_real &>compile_em_real.log
    [Guest@it01-r4-ln-01:WRFV3]
    [5] Done ./compile em_fire &>compile_em_fire.log
    [Guest@it01-r4-ln-01:WRFV3]
    [Guest@it01-r4-ln-01:WRFV3]

    if fgrep -iq '!$OMP' module_initialize_fire.f90 ; then \
    if [ -n "" ] ; then echo COMPILING module_initialize_fire.F WITH OMP ; fi ; \
    mpif90 -q64 -o module_initialize_fire.o -c -O3 -qtune=ppc970 -qarch=ppc970 -w -qspill=20000 -qmaxmem=32767 -qfree=f90 -I../dyn_em -I../dyn_nmm -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/esmf_time
    _f90 -I/home/Guest/wps/wrf-fire/wrfv2_fire/main -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_netcdf -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_int -I/home/Guest/wps/wrf-fire/wrfv2_fire/f
    rame -I/home/Guest/wps/wrf-fire/wrfv2_fire/share -I/home/Guest/wps/wrf-fire/wrfv2_fire/phys -I/home/Guest/wps/wrf-fire/wrfv2_fire/chem -I/home/Guest/wps/wrf-fire/wrfv2_fire/inc -I/home/Guest/wps/w
    rf-fire/WRFV3/netcdf_links/include -qrealsize=4 -qintsize=4 -qsuffix=f=f90 module_initialize_fire.f90 ; \
    else \
    if [ -n "" ] ; then echo COMPILING module_initialize_fire.F WITHOUT OMP ; fi ; \
    mpif90 -q64 -o module_initialize_fire.o -c -O3 -qtune=ppc970 -qarch=ppc970 -w -qspill=20000 -qmaxmem=32767 -qfree=f90 -I../dyn_em -I../dyn_nmm -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/esmf_time_
    f90 -I/home/Guest/wps/wrf-fire/wrfv2_fire/main -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_netcdf -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_int -I/home/Guest/wps/wrf-fire/wrfv2_fire/fr
    ame -I/home/Guest/wps/wrf-fire/wrfv2_fire/share -I/home/Guest/wps/wrf-fire/wrfv2_fire/phys -I/home/Guest/wps/wrf-fire/wrfv2_fire/chem -I/home/Guest/wps/wrf-fire/wrfv2_fire/inc -I/home/Guest/wps/wr
    f-fire/WRFV3/netcdf_links/include -qrealsize=4 -qintsize=4 -qsuffix=f=f90 module_initialize_fire.f90 ; \
    fi
    gfortran: error: unrecognized command line option ‘-q64’
    gfortran: error: unrecognized command line option ‘-qtune=ppc970’
    gfortran: error: unrecognized command line option ‘-qarch=ppc970’
    gfortran: error: unrecognized command line option ‘-qspill=20000’
    gfortran: error: unrecognized command line option ‘-qmaxmem=32767’
    gfortran: error: unrecognized command line option ‘-qfree=f90’
    gfortran: error: unrecognized command line option ‘-qrealsize=4’
    gfortran: error: unrecognized command line option ‘-qintsize=4’
    gfortran: error: unrecognized command line option ‘-qsuffix=f=f90’
    make[2]: [module_initialize_fire.o] Error 1 (ignored)
    make[2]: Leaving directory `/home/Guest/wps/wrf-fire/wrfv2_fire/dyn_em'
    rm -f ../frame/module_machine.o
    /opt/ibmcmp/xlf/11.1/exe/cpp -C -P -I/home/Guest/wps/wrf-fire/wrfv2_fire/inc -DEM_CORE=1 -DNMM_CORE=0 -DNMM_MAX_DIM=2600 -DCOAMPS_CORE=0 -DDA_CORE=0 -DEXP_CORE=0 -DIWORDSIZE=4 -DDWORDSIZE=8 -DRWORDSIZE=4 -DLW
    ORDSIZE=4 -DMOVE_NL_OUTSIDE_MODULE_CONFIGURE -DNONSTANDARD_SYSTEM_SUBR -DLANDREAD_STUB -DVERY_LARGE_MAXPROC=36768 -DDM_PARALLEL -DNETCDF -DMOVE_NESTS -DVORTEX_CENTER -DUSE_ALLOCATABLES -DGRIB1 -DINTIO -DLIMIT_A
    RGS -DCONFIG_BUF_LEN=65536 -DMAX_DOMAINS_F=21 -DMAX_HISTORY=25 -DNMM_NEST=0 -I. ../frame/module_machine.F > ../frame/module_machine.bb
    /bin/sh: /opt/ibmcmp/xlf/11.1/exe/cpp: No such file or directory
    make[1]: [../frame/module_machine.o] Error 127 (ignored)
    /home/Guest/wps/wrf-fire/wrfv2_fire/tools/standard.exe ../frame/module_machine.bb | /opt/ibmcmp/xlf/11.1/exe/cpp -C -P > ../frame/module_machine.f90
    /bin/sh: /opt/ibmcmp/xlf/11.1/exe/cpp: No such file or directory
    make[1]: [../frame/module_machine.o] Error 127 (ignored)
    rm -f ../frame/module_machine.b ../frame/module_machine.bb
    if fgrep -iq '!$OMP' ../frame/module_machine.f90 ; then \
    if [ -n "" ] ; then echo COMPILING ../frame/module_machine.F WITH OMP ; fi ; \
    mpif90 -q64 -o ../frame/module_machine.o -c -O3 -qtune=ppc970 -qarch=ppc970 -w -qspill=20000 -qmaxmem=32767 -qfree=f90 -I../dyn_em -I../dyn_nmm -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/esmf_tim
    e_f90 -I/home/Guest/wps/wrf-fire/wrfv2_fire/main -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_netcdf -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_int -I/home/Guest/wps/wrf-fire/wrfv2_fire/
    frame -I/home/Guest/wps/wrf-fire/wrfv2_fire/share -I/home/Guest/wps/wrf-fire/wrfv2_fire/phys -I/home/Guest/wps/wrf-fire/wrfv2_fire/chem -I/home/Guest/wps/wrf-fire/wrfv2_fire/inc -I/home/Guest/wps/
    wrf-fire/WRFV3/netcdf_links/include -qrealsize=4 -qintsize=4 -qsuffix=f=f90 ../frame/module_machine.f90 ; \
    else \
    if [ -n "" ] ; then echo COMPILING ../frame/module_machine.F WITHOUT OMP ; fi ; \
    mpif90 -q64 -o ../frame/module_machine.o -c -O3 -qtune=ppc970 -qarch=ppc970 -w -qspill=20000 -qmaxmem=32767 -qfree=f90 -I../dyn_em -I../dyn_nmm -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/esmf_time
    _f90 -I/home/Guest/wps/wrf-fire/wrfv2_fire/main -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_netcdf -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_int -I/home/Guest/wps/wrf-fire/wrfv2_fire/f
    rame -I/home/Guest/wps/wrf-fire/wrfv2_fire/share -I/home/Guest/wps/wrf-fire/wrfv2_fire/phys -I/home/Guest/wps/wrf-fire/wrfv2_fire/chem -I/home/Guest/wps/wrf-fire/wrfv2_fire/inc -I/home/Guest/wps/w
    rf-fire/WRFV3/netcdf_links/include -qrealsize=4 -qintsize=4 -qsuffix=f=f90 ../frame/module_machine.f90 ; \
    fi
    gfortran: error: unrecognized command line option ‘-q64’
    gfortran: error: unrecognized command line option ‘-qtune=ppc970’
    gfortran: error: unrecognized command line option ‘-qarch=ppc970’
    gfortran: error: unrecognized command line option ‘-qspill=20000

    rm -f ../share/module_io_domain.o
    /opt/ibmcmp/xlf/11.1/exe/cpp -C -P -I/home/Guest/wps/wrf-fire/wrfv2_fire/inc -DEM_CORE=1 -DNMM_CORE=0 -DNMM_MAX_DIM=2600 -DCOAMPS_CORE=0 -DDA_CORE=0 -DEXP_CORE=0 -DIWORDSIZE=4 -DDWORDSIZE=8 -DRWORDSIZE=4 -DLW
    ORDSIZE=4 -DMOVE_NL_OUTSIDE_MODULE_CONFIGURE -DNONSTANDARD_SYSTEM_SUBR -DLANDREAD_STUB -DVERY_LARGE_MAXPROC=36768 -DDM_PARALLEL -DNETCDF -DMOVE_NESTS -DVORTEX_CENTER -DUSE_ALLOCATABLES -DGRIB1 -DINTIO -DLIMIT_A
    RGS -DCONFIG_BUF_LEN=65536 -DMAX_DOMAINS_F=21 -DMAX_HISTORY=25 -DNMM_NEST=0 -I. ../share/module_io_domain.F > ../share/module_io_domain.bb
    /bin/sh: /opt/ibmcmp/xlf/11.1/exe/cpp: No such file or directory
    make[1]: [../share/module_io_domain.o] Error 127 (ignored)
    /home/Guest/wps/wrf-fire/wrfv2_fire/tools/standard.exe ../share/module_io_domain.bb | /opt/ibmcmp/xlf/11.1/exe/cpp -C -P > ../share/module_io_domain.f90
    /bin/sh: /opt/ibmcmp/xlf/11.1/exe/cpp: No such file or directory
    make[1]: [../share/module_io_domain.o] Error 127 (ignored)
    rm -f ../share/module_io_domain.b ../share/module_io_domain.bb
    if fgrep -iq '!$OMP' ../share/module_io_domain.f90 ; then \
    if [ -n "" ] ; then echo COMPILING ../share/module_io_domain.F WITH OMP ; fi ; \
    mpif90 -q64 -o ../share/module_io_domain.o -c -O3 -qtune=ppc970 -qarch=ppc970 -w -qspill=20000 -qmaxmem=32767 -qfree=f90 -I../dyn_em -I../dyn_nmm -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/esmf_t
    ime_f90 -I/home/Guest/wps/wrf-fire/wrfv2_fire/main -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_netcdf -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_int -I/home/Guest/wps/wrf-fire/wrfv2_fir
    e/frame -I/home/Guest/wps/wrf-fire/wrfv2_fire/share -I/home/Guest/wps/wrf-fire/wrfv2_fire/phys -I/home/Guest/wps/wrf-fire/wrfv2_fire/chem -I/home/Guest/wps/wrf-fire/wrfv2_fire/inc -I/home/Guest/wp
    s/wrf-fire/WRFV3/netcdf_links/include -qrealsize=4 -qintsize=4 -qsuffix=f=f90 ../share/module_io_domain.f90 ; \
    else \
    if [ -n "" ] ; then echo COMPILING ../share/module_io_domain.F WITHOUT OMP ; fi ; \
    mpif90 -q64 -o ../share/module_io_domain.o -c -O3 -qtune=ppc970 -qarch=ppc970 -w -qspill=20000 -qmaxmem=32767 -qfree=f90 -I../dyn_em -I../dyn_nmm -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/esmf_ti
    me_f90 -I/home/Guest/wps/wrf-fire/wrfv2_fire/main -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_netcdf -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_int -I/home/Guest/wps/wrf-fire/wrfv2_fire
    /frame -I/home/Guest/wps/wrf-fire/wrfv2_fire/share -I/home/Guest/wps/wrf-fire/wrfv2_fire/phys -I/home/Guest/wps/wrf-fire/wrfv2_fire/chem -I/home/Guest/wps/wrf-fire/wrfv2_fire/inc -I/home/Guest/wps
    /wrf-fire/WRFV3/netcdf_links/include -qrealsize=4 -qintsize=4 -qsuffix=f=f90 ../share/module_io_domain.f90 ; \
    fi
    gfortran: error: unrecognized command line option ‘-q64’
    gfortran: error: unrecognized command line option ‘-qtune=ppc970’
    gfortran: error: unrecognized command line option ‘-qarch=ppc970’
    gfortran: error: unrecognized command line option ‘-qspill=20000’
    gfortran: error: unrecognized command line option ‘-qmaxmem=32767’
    gfortran: error: unrecognized command line option ‘-qfree=f90’
    gfortran: error: unrecognized command line option ‘-qrealsize=4’
    gfortran: error: unrecognized command line option ‘-qintsize=4’
    gfortran: error: unrecognized command line option ‘-qsuffix=f=f90’
    make[1]: [../share/module_io_domain.o] Error 1 (ignored)
    rm -f ideal_em.o
    /opt/ibmcmp/xlf/11.1/exe/cpp -C -P -I/home/Guest/wps/wrf-fire/wrfv2_fire/inc -DEM_CORE=1 -DNMM_CORE=0 -DNMM_MAX_DIM=2600 -DCOAMPS_CORE=0 -DDA_CORE=0 -DEXP_CORE=0 -DIWORDSIZE=4 -DDWORDSIZE=8 -DRWORDSIZE=4 -DLW
    ORDSIZE=4 -DMOVE_NL_OUTSIDE_MODULE_CONFIGURE -DNONSTANDARD_SYSTEM_SUBR -DLANDREAD_STUB -DVERY_LARGE_MAXPROC=36768 -DDM_PARALLEL -DNETCDF -DMOVE_NESTS -DVORTEX_CENTER -DUSE_ALLOCATABLES -DGRIB1 -DINTIO -DLIMIT_A
    RGS -DCONFIG_BUF_LEN=65536 -DMAX_DOMAINS_F=21 -DMAX_HISTORY=25 -DNMM_NEST=0 -I. ideal_em.F > ideal_em.bb
    /bin/sh: /opt/ibmcmp/xlf/11.1/exe/cpp: No such file or directory
    make[1]: [ideal_em.o] Error 127 (ignored)
    /home/Guest/wps/wrf-fire/wrfv2_fire/tools/standard.exe ideal_em.bb | /opt/ibmcmp/xlf/11.1/exe/cpp -C -P > ideal_em.f90
    /bin/sh: /opt/ibmcmp/xlf/11.1/exe/cpp: No such file or directory
    make[1]: [ideal_em.o] Error 127 (ignored)
    rm -f ideal_em.b ideal_em.bb
    if fgrep -iq '!$OMP' ideal_em.f90 ; then \
    if [ -n "" ] ; then echo COMPILING ideal_em.F WITH OMP ; fi ; \
    mpif90 -q64 -o ideal_em.o -c -O3 -qtune=ppc970 -qarch=ppc970 -w -qspill=20000 -qmaxmem=32767 -qfree=f90 -I../dyn_em -I../dyn_nmm -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/esmf_time_f90 -I/home/
    Guest/wps/wrf-fire/wrfv2_fire/main -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_netcdf -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_int -I/home/Guest/wps/wrf-fire/wrfv2_fire/frame -I/home/s
    prakash/wps/wrf-fire/wrfv2_fire/share -I/home/Guest/wps/wrf-fire/wrfv2_fire/phys -I/home/Guest/wps/wrf-fire/wrfv2_fire/chem -I/home/Guest/wps/wrf-fire/wrfv2_fire/inc -I/home/Guest/wps/wrf-fire/WRFV3/
    netcdf_links/include -qrealsize=4 -qintsize=4 -qsuffix=f=f90 ideal_em.f90 ; \
    else \




    if [ -n "" ] ; then echo COMPILING ideal_em.F WITHOUT OMP ; fi ; \
    mpif90 -q64 -o ideal_em.o -c -O3 -qtune=ppc970 -qarch=ppc970 -w -qspill=20000 -qmaxmem=32767 -qfree=f90 -I../dyn_em -I../dyn_nmm -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/esmf_time_f90 -I/home/Guest/wps/wrf-fire/wrfv2_fire/main -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_netcdf -I/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_int -I/home/Guest/wps/wrf-fire/wrfv2_fire/frame -I/home/Guest/wps/wrf-fire/wrfv2_fire/share -I/home/Guest/wps/wrf-fire/wrfv2_fire/phys -I/home/Guest/wps/wrf-fire/wrfv2_fire/chem -I/home/Guest/wps/wrf-fire/wrfv2_fire/inc -I/home/Guest/wps/wrf-fire/WRFV3/netcdf_links/include -qrealsize=4 -qintsize=4 -qsuffix=f=f90 ideal_em.f90 ; \
    fi
    gfortran: error: unrecognized command line option ‘-q64’
    gfortran: error: unrecognized command line option ‘-qtune=ppc970’
    gfortran: error: unrecognized command line option ‘-qarch=ppc970’
    gfortran: error: unrecognized command line option ‘-qspill=20000’
    gfortran: error: unrecognized command line option ‘-qmaxmem=32767’
    gfortran: error: unrecognized command line option ‘-qfree=f90’
    gfortran: error: unrecognized command line option ‘-qrealsize=4’
    gfortran: error: unrecognized command line option ‘-qintsize=4’
    gfortran: error: unrecognized command line option ‘-qsuffix=f=f90’
    make[1]: [ideal_em.o] Error 1 (ignored)
    ranlib libwrflib.a
    ranlib: 'libwrflib.a': No such file
    make[1]: [em_ideal] Error 1 (ignored)
    mpif90 -q64 -o ideal.exe -O3 -qtune=ppc970 -qarch=ppc970 -w -qspill=20000 -qmaxmem=32767 -qfree=f90 ideal_em.o ../dyn_em/module_initialize_fire.o libwrflib.a /home/Guest/wps/wrf-fire/wrfv2_fire/external/fftpack/fftpack5/libfftpack.a /home/Guest/wps/wrf-fire/wrfv2_fire/external/io_grib1/libio_grib1.a /home/Guest/wps/wrf-fire/wrfv2_fire/external/io_grib_share/libio_grib_share.a /home/Guest/wps/wrf-fire/wrfv2_fire/external/io_int/libwrfio_int.a -L/home/Guest/wps/wrf-fire/wrfv2_fire/external/esmf_time_f90 -lesmf_time /home/Guest/wps/wrf-fire/wrfv2_fire/external/RSL_LITE/librsl_lite.a /home/Guest/wps/wrf-fire/wrfv2_fire/frame/module_internal_header_util.o /home/Guest/wps/wrf-fire/wrfv2_fire/frame/pack_utils.o -L/home/Guest/wps/wrf-fire/wrfv2_fire/external/io_netcdf -lwrfio_nf -L/home/Guest/wps/wrf-fire/WRFV3/netcdf_links/lib -lnetcdf
    gfortran: error: ideal_em.o: No such file or directory
    gfortran: error: ../dyn_em/module_initialize_fire.o: No such file or directory
    gfortran: error: libwrflib.a: No such file or directory
    gfortran: error: /home/Guest/wps/wrf-fire/wrfv2_fire/external/RSL_LITE/librsl_lite.a: No such file or directory
    gfortran: error: /home/Guest/wps/wrf-fire/wrfv2_fire/frame/pack_utils.o: No such file or directory
    gfortran: error: unrecognized command line option ‘-q64’
    gfortran: error: unrecognized command line option ‘-qtune=ppc970’
    gfortran: error: unrecognized command line option ‘-qarch=ppc970’
    gfortran: error: unrecognized command line option ‘-qspill=20000’
    gfortran: error: unrecognized command line option ‘-qmaxmem=32767’
    gfortran: error: unrecognized command line option ‘-qfree=f90’
    make[1]: [em_ideal] Error 1 (ignored)
    make[1]: Leaving directory `/home/Guest/wps/wrf-fire/wrfv2_fire/main'
    ( cd test/em_fire ; /bin/rm -f wrf.exe ; ln -s ../../main/wrf.exe . )
    ( cd test/em_fire ; /bin/rm -f ideal.exe ; ln -s ../../main/ideal.exe . )
    ( cd test/em_fire ; /bin/rm -f README.namelist ; ln -s ../../run/README.namelist . )
    ( cd test/em_fire ; /bin/rm -f gribmap.txt ; ln -s ../../run/gribmap.txt . )
    ( cd test/em_fire ; /bin/rm -f grib2map.tbl ; ln -s ../../run/grib2map.tbl . )
    ( cd test/em_fire ; /bin/sh create_links.sh )
    ( cd run ; /bin/rm -f ideal.exe ; ln -s ../main/ideal.exe . )
    ( cd run ; if test -f namelist.input ; then \
    /bin/cp -f namelist.input namelist.input.backup ; fi ; \
    /bin/rm -f namelist.input ; ln -s ../test/em_fire/namelist.input . )
    ( cd run ; /bin/rm -f input_sounding ; ln -s ../test/em_fire/input_sounding . )
    build started: Fri Nov 2 19:56:18 ECT 2018
    build completed: Fri Nov 2 19:56:25 ECT 2018





2)
[Guest@it01-r4-ln-01:WRFV3] uname -a
Linux it01-r4-ln-01.Guestamis.ep 3.10.0-327.el7.ppc64le #1 SMP Thu Oct 29 17:31:13 EDT 2015 ppc64le ppc64le ppc64le GNU/Linux
[Guest@it01-r4-ln-01:WRFV3] uname -m
ppc64le
[Guest@it01-r4-ln-01:WRFV3]


3) [Guest@Guest ar-kappa-70]$ gfortran -v
Using built-in specs.
COLLECT_GCC=gfortran
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/6.3.1/lto-wrapper
Target: x86_64-redhat-linux
Configured with: ../configure --enable-bootstrap --enable-languages=c,c++,objc,obj-c++,fortran,ada,go,lto --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-shared --enable-threads=posix --enable-checking=release --enable-multilib --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-linker-hash-style=gnu --enable-plugin --enable-initfini-array --disable-libgcj --with-isl --enable-libmpx --enable-gnu-indirect-function --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux
Thread model: posix
gcc version 6.3.1 20161221 (Red Hat 6.3.1-1) (GCC)
saravan
 
Posts: 3
Joined: Wed Oct 31, 2018 11:52 pm

Re: WPS, Enter selection [1-0] , Why this problem

Postby kwthomas » Mon Nov 05, 2018 4:37 pm

1) WRF Model Version 3.4 (April 6, 2012)

2) uname -m
ppc64le

This gives me what I need to know. You are running a rather obsolete version of WRF. WRF prior to
version 3.7 doesn't support "ppc64le" machines. Starting with WRF 3.7, "ppc64le" support is in there
for Gfortran, Portland, Intel, PathScale and "xlf" compilers. That means your builds should be clean.

Although it is possible to backport the "ppc64le" support to WRF 3.4, I recommend upgrading to at least
WRF 3.7.1. A later version is better. CAPS ran WRF 3.9.1.1 last spring. We'll be using WRF 4.0.1 next
spring.
Kevin W. Thomas
Center for Analysis and Prediction of Storms
University of Oklahoma
kwthomas
 
Posts: 249
Joined: Thu Aug 07, 2008 6:53 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest